This is an unfortunately specific question, I'd much rather ask something more generic, but I'm just stumped. I install the latest Linux Mint, then I go to the NordVPN site and follow the guide to install NordVPN there, and ... nothing. I follow the companies own guide. https://support.nordvpn.com/Connectivity/Linux/1325531132/Installing-and-using-NordVPN-on-Debian-Ubuntu-Raspberry-Pi-Elementary-OS-and-Linux-Mint.htm

sh <(curl -sSf https://downloads.nordcdn.com/apps/linux/install.sh)
nordvpn login
nordvpn connect

It accepts my login credentials and then says "Close this window to return to the app?" so I do that and go back to the console, then it just says "You are not logged into NordVPN" if I try to run any command.

Can someone with Ubuntu/Debian/LinuxMint related experience with NordVPN point out what I'm missing or doing wrong please?

2 Answers 2


I can't really tell what went wrong for you because I didn't use that script, but I can recount how I managed to set things up a few weeks ago (still on Mint 19, though).

I got a bit confused because that guide has a link "Download the NordVPN Linux client" that leads to a page where you get a .deb file instead of the shell script, but that worked for me. So:

  1. curl -O https://repo.nordvpn.com/deb/nordvpn/debian/pool/main/nordvpn-release_1.0.0_all.deb
  2. sudo apt install ./nordvpn-release_1.0.0_all.deb
  3. sudo apt update
  4. sudo apt install nordvpn
  5. re-login or run su - $USER (the previous step prints a message that this is necessary)
  6. nordvpn login
  7. a login page opens in the browser, log in there
  8. the "Return to the app" link there didn't work for me, so I copied the URL
  9. nordvpn login --callback <copied_URL>

After that nordvpn connect <country> worked.

  • Thanks so much for looking at this. It's just incredibly broken. You'd think these people would make sure it works, but nope, and I see this with so many things on Linux, always broken and the companies never bother to fix it.
    – YorSubs
    Jan 17, 2022 at 0:36
  • boss@loft:~$ nordvpn login Continue in the browser: zwyr157wwiu6eior.com/v1/users/oauth/… boss@loft:~$ nordvpn account You are not logged in. boss@loft:~$ nordvpn login --callback nordvpn://login?action=login&exchange_token=ZWJlODhmOTM5NWRjNjZlZTM4NjMzMmQ1MTcyYWQ5MTQwYTYxMTM5NDlmYzQ3Y2I5NzNjZmVmNTg5NjhjYmI0OA%3D%3D&status=done [1] 119406 [2] 119407 Exchange token not provided.
    – YorSubs
    Jan 17, 2022 at 0:36
  • [1]- Exit 1 nordvpn login --callback nordvpn://login?action=login [2]+ Done exchange_token=ZWJlODhmOTM5NWRjNjZlZTM4NjMzMmQ1MTcyYWQ5MTQwYTYxMTM5NDlmYzQ3Y2I5NzNjZmVmNTg5NjhjYmI0OA%3D%3D
    – YorSubs
    Jan 17, 2022 at 0:37
  • The above is what I get when I copy the URK from the page and try to run it as you said. It's just completely broken, and it's very disappointing. 😕
    – YorSubs
    Jan 17, 2022 at 0:38
  • 2
    The URL contains & characters that you haven't escaped on the command line, that's not really a problem of the tool. Does it work when you put the URL in quotes in step 9?
    – DonHolgo
    Jan 17, 2022 at 9:07

Adding this in case someone misses it. I got stuck on this on Ubunu:

nordvpn login --callback nordvpn://login?action=login&exchange_token=XXXXX&status=done

To fix it, I had to add the link in quotes:

nordvpn login --callback "nordvpn://login?action=login&exchange_token=XXXXX&status=done"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .