1

I have a Raspberry 4B with Debian 11.2 installed. I could successfully install snapd. Trying to run "snap install core" resulted in an error telling that filesystem "squashfs" is not supported.

The kernel version is "5.4.72-v7l+" (output of "uname -r").

A friend of mine also has a Raspberry 4B. He installed snapd and he could also run successfully "snap install core" and "snap refresh core". However, the version of his kernel (Debian 11.2) is "5.10.63-v8+".

Both he and me, in our /etc/apt/sources.list file is:

deb http://raspbian.raspberrypi.org/raspbian/ bullseye main contrib non-free rpi

There are some questions:

  1. Why do the kernel versions differ?
  2. How can I get the latest kernel version (without re-compiling it)? Note that I regularly run "apt-get dist-upgrade -y"
  3. How to enable support for squashfs?

When reading the 8-years old post Force Debian kernel version it was obviously not so easy to force a more recent kernel version. However that post did not help me much.

Any suggestions welcome!


@Eduardo

modprobe squashfs results in:

modprobe: FATAL: Module squashfs not found in directory /lib/modules/5.4.72-v7l+

NOTE:

  1. There is NO directory /lib/modules/5.4.72-v7l+
  2. There is directory /lib/modules/4.9.35-v7+
  3. find /lib/modules/4.9.35-v7+/kernel -name "squash" outputs:

/lib/modules/4.9.35-v7+/kernel/fs/squashfs

/lib/modules/4.9.35-v7+/kernel/fs/squashfs/squashfs.ko

3
  • Have you tried running sudo modprobe squashfs first? Commented Jan 15, 2022 at 17:05
  • "Have you tried turning it off and on again?" - just asking, there is no other way to load the new kernel.
    – FelixJN
    Commented Jan 15, 2022 at 18:07
  • I deinstalled snapd, rebooted, ran apt-get update && apt-get upgrade and installed snapd again. Same problem. Dieter
    – DieterH
    Commented Jan 15, 2022 at 19:57

0

You must log in to answer this question.

Browse other questions tagged .