1

My computer won't boot anymore I think because it ran out of disk space. It asks to boot in low graphics mode and then gets stuck checking battery state. When I boot in recovery mode I run clean and it says it's okay and gets stuck. I go to root terminal and try to delete things or run apt-get and I can't because I can't delete the lock file or anything else. Any ideas?

2
  • 1
    First boot a live CD and run fsck.
    – goldilocks
    Mar 20, 2013 at 23:49
  • Run df -k to check for full disks.
    – vonbrand
    Mar 21, 2013 at 1:06

3 Answers 3

1

Usually if the Linux OS changes a mount to RO, then there is some type of driver or serious structural error in the filesystem has happened. Please before you possibly damage the disk further, do a FULL fsck on the disk.

1
  • This is the way to go. Let fsck have a crack at repairing it. If you have a state in which the file system is mounted read-only, you should immediately backup everything you might need should a reformat and reinstall be required.
    – Faelkle
    Oct 24, 2013 at 23:06
0

This is just a solution which worked for me:

1) press ALT CTRLF2

2) login whith your credentials

3) enter sudo pkill X

X server will restart and login screen will come up..

0

Get into recovery mode and type

mount -o remount,rw /

You should have your read-write mode set

1
  • I wouldn't remount the filesystem rw until you're sure it isn't corrupt. Doing this on a bad filesystem is probably going to make things worse.
    – Faelkle
    Oct 24, 2013 at 23:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .