0

So. I installed Debian on my asus laptop, resized the windows partition, and installed Debian 11(stable). windows was automatically add to grub and everything was good. I apt update && apt upgrade, and when I went to reboot, windows boot was gone. All the partitions look like they're still there.

  1. Disk /dev/mmcblk0: 116.48 GiB, 125069950976 bytes, 244277248 sectors
  2. Units: sectors of 1 * 512 = 512 bytes
  3. Sector size (logical/physical): 512 bytes / 512 bytes
  4. I/O size (minimum/optimal): 512 bytes / 512 bytes
  5. Disklabel type: gpt
  6. Disk identifier: 32BD2B1E-DBD1-4782-93F4-A9EA7A7AC78E
  • Device Start End Sectors Size Type
  • /dev/mmcblk0p1 157390848 158439423 1048576 512M EFI System
  • /dev/mmcblk0p2 534528 567295 32768 16M Microsoft reserved
  • /dev/mmcblk0p3 567296 157388804 156821509 74.8G Microsoft basic data
  • /dev/mmcblk0p4 158439424 240431103 81991680 39.1G Linux filesystem
  • /dev/mmcblk0p5 242432000 243865599 1433600 700M BIOS boot
  • /dev/mmcblk0p6 243865600 244275199 409600 200M Windows recovery environment
  • /dev/mmcblk0p7 240431104 242431999 2000896 977M Linux swap

but I can't seem to get windows to boot. It's not an option in the bios either. shows 2 debian options, which is weird. anyways, I've looked all over qnd haven't found anything that would even pointme in the right direction. please helpo. thanks.

6
  • You should always have a Windows boot option in UEFI boot menu. But you show both ESP - efi system partition for UEFI boot and bios_grub (BIOS boot) for BIOS boot on gpt drive. Those are not compatible. All systems should be UEFI. Grub also removing os-prober for security reason for now. Please copy & paste the pastebin link to the Bootinfo summary report ( do not post report), do not run the auto fix till reviewed.Lets see details, use ppa version with your USB installer (2nd option) or any working install, not Boot-Repair ISO help.ubuntu.com/community/Boot-Repair
    – oldfred
    Jan 13 at 3:33
  • pastebin.com/GDRKrrs3 and I'm working on finding the ppa for boot-repair.
    – caspah
    Jan 13 at 5:14
  • I dunno if you got my last post, but here, pastebin.com/GDRKrrs3. IT's set to burn in an hour. lemme know if you can't see it, plus I'mhaving mad issues installed boot-repair. I'm thinking it because its designed for unbuntu? I dunno. Imma keep trying,
    – caspah
    Jan 13 at 6:23
  • I cannot look at paste. Never seen the burn after looking once. We all are volunteers and others should also look at it and see something I miss.
    – oldfred
    Jan 13 at 12:54
  • pastebin.com/PG9U4ML5
    – caspah
    Jan 15 at 13:59

1 Answer 1

1

In a recent version of Grub in debian the defaults were changed.

By default, grub's setup scripts no longer scan for other OSen.

This behaviour was documented at https://wiki.debian.org/Grub :

When I upgraded from GRUB to GRUB2 I lost an entry to XP/WP7 , how can I recover the menu entry to boot there?

You have to install os-prober, make sure its enabled in GRUB2 configuration and sync GRUB2.

apt-get install os-prober

Then edit /etc/default/grub and make sure you have a line like

GRUB_DISABLE_OS_PROBER=false

I had the same issue while updating a legacy system, and this worked for me.

3
  • so I tried that and nothing changed. I've been playing with different dist of linux starting with 18 floppys to install redhat and I deleted the windows partition on my parents $1500 computer, so I thought of myself as somewhat knowledgeable.. guess not. here's a boot repair report. anyways, please help. Pastebin.ubuntu.com/p/D3ysh4DzYF
    – caspah
    Jan 13 at 12:17
  • I don't have a ubuntu.com login and can't view that pastebin. Include the actual text in an edit of the actual question.
    – Shadur
    Jan 13 at 12:42
  • it's way to much to post here. try this. pastebin.com/h76nqwTS
    – caspah
    Jan 13 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.