10

We have a system that's been a bit sluggish. top reports that console-kit-daemon takes anywhere from 18-30% CPU and about 50% memory. There are only two users logged in, one on X and one via ssh.

Any ideas how to resolve this?

Running Debian. uname reports:

Linux bulls5 2.6.32-5-686 #1 SMP Sun Sep 23 09:49:36 UTC 2012 i686 GNU/Linux

First few lines of top:

 9456 root      20   0 2006m 1.8g 2020 S   19 50.2   1788:50 console-kit-dae  
 1501 messageb  20   0  425m 397m  796 S    0 10.6 230:20.64 dbus-daemon  
 3799 tomcat6   20   0  932m 450m 7208 S    0 12.0 106:36.35 java 
24383 postgres  20   0 48312 7956 5640 S    0  0.2   0:00.44 postgres 
27239 root      20   0  8672 3092 2544 S    0  0.1   0:00.01 sshd 
27304 root      20   0  8672 3092 2544 S    0  0.1   0:00.01 sshd
  • ConsoleKit manages console logins in graphical mode (i.e. with gdm or equivalent), if you don't need it, you can kill easily and free your memory and cpu usage.Sound like you run graphical env... is true? – PersianGulf Mar 20 '13 at 18:55
  • @Mohsen Yes, and unfortunately it's a requirement for the primary user, so I can't just kill ConsoleKit. I was thinking it might be a version issue, but we're pretty close to being completely up to date; I've just run out of ideas to try. – Michael Todd Mar 20 '13 at 19:00
  • Perhaps htop in tree mode (F5) can give more info? Or even pstree -pacs PID ... – Runium Mar 20 '13 at 20:33
  • @Sukminder That displays a list of 63 lines, I'm assuming threads, associated with console-kit. I have a feeling that these threads are getting started and not shut down properly (hence the memory use). Any suggestions as to how to do that other than manually killing them? – Michael Todd Mar 20 '13 at 20:37
  • No. I don't know. Hopefully someone do. Only had a quick peek at bugzilla.redhat.com/show_bug.cgi?id=473547#c44 , bugs.freedesktop.org/show_bug.cgi?id=17720#c17 and the like ... - Perhaps Mr. Poettering has a web-alert on console-kit :P – Runium Mar 20 '13 at 21:12
7
  1. Kill the console-kit-daemon process if it's still running.
  2. Remove the file
    /usr/share/dbus-1/system-service/org.freedesktop.ConsoleKit.service
    (or move it to some place where you could restore it, if necessary).
  3. Reboot and you will see that console-kit-daemon no longer automatically starts up.
| improve this answer | |
3

I disabled it by removing the executable's exec permission:

chmod -x /usr/sbin/console-kit-daemon
| improve this answer | |
  • You're making the file executable with that flag. – knutole Aug 18 '15 at 14:05
  • 1
    @knutole No, Andreas isn't. His code correctly removes the x bit, according to the man page and tested on my machine. – GKFX Feb 22 '16 at 18:45
  • 1
    @GKFX You're right. – knutole Feb 23 '16 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.