1

I am trying to install snap on my rhel 8.4 machine and it throws the following error

Error: 
 Problem: package snapd-2.54.1-1.el8.x86_64 requires snapd-selinux = 2.54.1-1.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides selinux-policy-base >= 3.14.3-80.el8_5.2 needed by snapd-selinux-2.54.1-1.el8.noarch

I have selinux-policy-3.14.3-67.el8_4.2 on my machine.

3
  • Add the output of subscription-manager repos --list to the question. Jan 9 at 14:19
  • I get "This system has no repositories available through subscriptions" Jan 9 at 17:03
  • Add it to the question as well as the output of subscription-manager status. Do not post it in the comments. Jan 9 at 19:37

2 Answers 2

1

The fundamental problem is as described by the error:

nothing provides selinux-policy-base >= 3.14.3-80.el8_5.2

Since none of your repos can provide this dependency, the installation cannot continue.

It seems that similar issues have happened before, and in that case the RHEL repos were simply lagging behind. You can try sudo dnf upgrade --refresh again and see if the package is now available. If not, I don't think there's a good solution to this issue without including third party repositories (which is likely not a good idea).

As you can see here: https://pkgs.org/download/selinux-policy-base

...version 3.14.3-80 is currently available both on AlmaLinux and Rocky Linux, which are binary compatible with RHEL. It seems strange that RHEL would not have the package considering they are upstream to both of them.

Perhaps you are using a satellite repo that is out of date with upstream? You should investigate your repos as the source of this error I think.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.