1

Apparently something changed on my system and instead of shutting down in 500 milliseconds, it now has to wait 1 minute and 30 seconds due to some unknown process holding it up. The plymouth shutdown screen says something similar to "a stop job is running for session 2".

Is there any way I can completely disable all "timeouts" for shutdown of systemd services and force the computer to shut down instantly under any circumstances? I don't want to wait for a stop job to complete, if I press the power button it should shut down instantly no matter what is running on the system.

Also, are there any logs to view or tools which can show which process is holding up the shutdown process? I know systemd-analyze works for bootup, is there an equivalent for shutdown delays?

My research on setting the timeout to a low value apparently only applies to singular systemd services, and I could not find a way to configure a timeout of 1 second system wide.

I'm on Debian unstable.

1
  • Also looks like the SELinux context my user account running under did not have the "system stop" capability allowed, so it was not able to stop other sessions without waiting for the system to end them. Jan 6 at 16:36

1 Answer 1

1
/etc/systemd/system.conf.d/system.conf

[Manager]
DefaultTimeoutStopSec=2s

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.