1

For unrelated reasons (XWayland crashing the Bash too often with applications like gnuplot, firefox...) I'm trying to start the "Gnome on X11" when login into my Fedora 35 laptop. This is basically done by typing my user name into the login-screen and selecting not the default GNOME but the alternative GNOME on X11 and the continuing by typing the password.

The problem is: when the "Activities" and "xterm" are selected this ends up in a Bash-shell where $HOME is set to /root, where I expect to have /home/$USER, and none of .login, .bashrc or .bash-login seem to be executed. [No such incomplete setup is seen for the Wayland-gnome.] The xdg environment variables are set as expected

XDG_MENU_PREFIX=gnome-
XDG_SESSION_DESKTOP=gnome-xorg
XDG_SESSION_TYPE=x11
XDG_CURRENT_DESKTOP=GNOME
XDG_SESSION_CLASS=user
XDG_RUNTIME_DIR=/run/user/1000

The file /etc/environment is empty. The question is: how to I get the default behaviour for gnome-x11 bash environment initialization on Fedora 35?

  • The same behaviour happens when a gnome-terminal is started instead of a xterm

  • /etc/passwd contains the correct home directory

  • The /usr/bin/gnome-session script starts a shell named by $SHELL only if the session is a wayland session. Is this restriction intended?

  • /usr/share/applications/xterm.desktop looks alright and does not seem to care about $HOME

  • There is no setting of HOME in any of the /etc/gdm directories.

  • There is no setting of HOME in any of the /etc/X11 directories.

  • There is no setting of HOME in any of the /etc/profile.d directories.

  • There is no .gdmrc in my (correct) $HOME directory.

  • The same problem exists on Fedora 34

1
  • I'm not on Fedora 35 yet, but gnome on X11 works fine for me on a previous Fedora version. My xterm launch works but I almost always use gnome-terminal. Does your /usr/share/applications/xterm.desktop look normal?
    – rickhg12hs
    Commented Jan 5, 2022 at 19:13

0

You must log in to answer this question.

Browse other questions tagged .