0

The wifi adapter in my laptop is Realtek RTL8852AE. I am currently dual-booting Windows 11 and Ubuntu 20.04.3 LTS. I've gone through multiple options for what it could be, installed rtw89's repository for the realtek driver. Another suggestion was that windows might be shutting off the adapter to conserve power, but an option for unticking that for the adapter wasn't available when I tried in Windows 11.

Edit: The powermanagement tab does not appear when I go to properties for my network adapter in windows. I've tried enabling it with the CsEnabled registry key in Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power and then rebooting, alas it does not appear.

sudo lshw -C network output :

*-network UNCLAIMED       
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: ioport:2000(size=256) memory:d1600000-d16fffff
  *-network
       description: Ethernet interface
       physical id: 2
       logical name: bnep0
       serial: 14:5a:fc:1e:03:3a
       capabilities: ethernet physical
       configuration: broadcast=yes ip=192.168.44.197 multicast=yes

output for sudo nmcli device:

DEVICE             TYPE      STATE      CONNECTION        
4C:4F:EE:E6:67:1F  bt        connected  OnePlus 8 Network 
lo                 loopback  unmanaged  --

(I'm bluetooth tethering from my phone)

7
  • github.com/lwfinger/rtw89 did you mean you used this driver? Post the outputs of lshw -C network and nmcli device
    – Alex
    Jan 4, 2022 at 16:25
  • Yes I used lwfinger's driver
    – Rell
    Jan 4, 2022 at 16:30
  • Please add this in the question's description, because it is hard to read as a comment. Also, run the commands with sudo
    – Alex
    Jan 4, 2022 at 16:33
  • I have also checked if any radiofunctions are blocked using sudo rfkill list all, but none of them are.
    – Rell
    Jan 4, 2022 at 17:25
  • Does this answer your question? is it possible `cat` files role in ansible?
    – waltinator
    Jan 4, 2022 at 18:26

2 Answers 2

0

It turns out I managed to fix my problem with

sudo modprobe -v rtw89pci

which seemed to randomly start working again... not sure what to tell you.

I also made a script for that command and saved it in case I happen to boot up and have the same problem again.

-1

Step 1 - Go to Bios Settings and disable Secure boot.

sudo apt update
sudo apt install -y git build-essential
git clone https://github.com/lwfinger/rtw89.git
cd rtw89
make
sudo make install
sudo mkdir /usr/lib/firmware/rtw89

If mkdir does not work use -p with it.

sudo mkdir -p /usr/lib/firmware/rtw89

sudo cp  rtw8852a_fw.bin  /usr/lib/firmware/rtw89/
sudo modprobe rtw89pci

If modeprobe does not work, secure boot may be enabled. Disable it from BIOS settings and retry it.

sudo modprobe rtw89pci

(Worked for HP laptop - Pavallion Gaming 15-ec2008AX )

3
  • You start with "Step 1", but then there aren't any other steps... Mar 7, 2022 at 5:54
  • There is no need to disable secureboot entirely for all installed OS just for loading a kernel module. There are multiple other options including signing the module with your MOK or disabling kernel lockdown. Mar 8, 2022 at 2:50
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Mar 16, 2022 at 17:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .