sudo apt install build-essential

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libr0 : Depends: libbinutils (< 2.31.2) but 2.35.2-2 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

apt policy libr0 shows

  Installed: 4:14.0.6-0debian10.0.0+0~a
  Candidate: 4:14.0.6-0debian10.0.0+0~a
  Version table:
 *** 4:14.0.6-0debian10.0.0+0~a 500
        500 http://q4os.org/qtderepo buster/main amd64 Packages
        100 /var/lib/dpkg/status

apt policy libbinutils shows

  Installed: 2.31.1-16
  Candidate: 2.35.2-2
  Version table:
     2.35.2-2 500
        500 http://ftp.de.debian.org/debian bullseye/main amd64 Packages
 *** 2.31.1-16 500
        500 http://ftp.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

and trying to upgrade libbinutils results in

WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  q4os-desktop tdelibs14-trinity (due to q4os-desktop)
  tdebase-trinity-bin (due to q4os-desktop)
  tdesudo-trinity (due to q4os-desktop)
  tde-style-q4oststyle02-trinity (due to q4os-desktop)
  twin-trinity (due to q4os-desktop) network-manager-tde (due to q4os-desktop

2 Answers 2


It seems your system is running Q4OS Centaurus, not Debian 11. Q4OS is based on Debian but isn’t Debian; it’s better to stick to whatever version of Debian your version of Q4OS is based on (Debian 10 in Q4OS Centaurus’ case).

Q4OS Gemini is based on Debian 11, so if you upgrade to that you’ll be able to use packages from Debian 11.


Resolve the E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages error message as follows.

  1. Open the /var/log/apt/term.log log file in a text editor.

  2. Locate any "broken" packages and remove them with sudo apt remove name-of-broken-package. You already know that there are Debian 10 packages installed on your operating system which is based on Debian 11 that are not compatible Debian 11. This will help you to locate some broken packages, but there may also be others. Don't uninstall your existing desktop environment without installing a new desktop environment to replace it and logging in to your new desktop environment.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .