sudo apt install build-essential Reading package lists... Done Building dependency tree... Done Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libr0 : Depends: libbinutils (< 2.31.2) but 2.35.2-2 is to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
apt policy libr0 shows
libr0: Installed: 4:14.0.6-0debian10.0.0+0~a Candidate: 4:14.0.6-0debian10.0.0+0~a Version table: *** 4:14.0.6-0debian10.0.0+0~a 500 500 http://q4os.org/qtderepo buster/main amd64 Packages 100 /var/lib/dpkg/status
apt policy libbinutils shows
libbinutils: Installed: 2.31.1-16 Candidate: 2.35.2-2 Version table: 2.35.2-2 500 500 http://ftp.de.debian.org/debian bullseye/main amd64 Packages *** 2.31.1-16 500 500 http://ftp.debian.org/debian buster/main amd64 Packages 100 /var/lib/dpkg/status
and trying to upgrade
libbinutils results in
WARNING: The following essential packages will be removed. This should NOT be done unless you know exactly what you are doing! q4os-desktop tdelibs14-trinity (due to q4os-desktop) tdebase-trinity-bin (due to q4os-desktop) tdesudo-trinity (due to q4os-desktop) tde-style-q4oststyle02-trinity (due to q4os-desktop) twin-trinity (due to q4os-desktop) network-manager-tde (due to q4os-desktop