1

I am using Debian 10.6.

$ sudo apt install openjdk-16-jre-headless
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package openjdk-16-jre-headless

Here is my package list. Notice how there is only openjdk 11, and nothing else.

$ apt search openjdk
Sorting... Done
Full Text Search... Done
default-jdk/oldstable 2:1.11-71 i386
  Standard Java or Java compatible Development Kit

default-jdk-doc/oldstable 2:1.11-71 amd64
  Standard Java or Java compatible Development Kit (documentation)

default-jdk-headless/oldstable,now 2:1.11-71 amd64 [installed,automatic]
  Standard Java or Java compatible Development Kit (headless)

default-jre/oldstable,now 2:1.11-71 amd64 [installed,automatic]
  Standard Java or Java compatible Runtime

default-jre-headless/oldstable,now 2:1.11-71 amd64 [installed,automatic]
  Standard Java or Java compatible Runtime (headless)

java-package/oldstable,oldstable 0.62 all
  Utility for creating Java Debian packages

jtreg/oldstable,oldstable 4.2-b14-1 all
  Regression Test Harness for the OpenJDK platform

libhsdis0-fcml/oldstable 1.1.3-3 amd64
  HotSpot disassembler plugin using FCML

libreoffice/oldstable 1:6.1.5-3+deb10u7 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
  office productivity suite (metapackage)

nvidia-openjdk-8-jre/oldstable 9.+8u77~9.2.148-7+deb10u1 amd64
  NVIDIA provided OpenJDK Java runtime, using Hotspot JIT

openjdk-11-dbg/oldstable 11.0.13+8-1~deb10u1 amd64

2 Answers 2

2

apt can’t locate openjdk-16-jre-headless because the OpenJDK 16 packages aren’t available in any Debian release.

The only release available to you in Debian 10 is OpenJDK 11. Debian 11 has OpenJDK 17. Both of these are releases with long-term support.

1

openjdk-16-jre-headless isn't packaged on Debian. You have to use openjdk-11-jre-headless, it can be installed after enabling the security repository.

Java and debian.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .