6

Whenever I login using the fingerprint sensor instead of the login password, a popup is displayed from gnome-keyring to enter the login password in order to unlock the various certificates that are stored there.

enter image description here

This is quite annoying, because it steals the focus, and doesn't let you do anything else until the password is entered. It won't even let you change the keyboard language, so if you had it in a different language than the password before the reboot, you are screwed. I wasn't even able to take a screenshot of the popup, which is why the quality of the picture is so low - it was from my mobile.

A partial solution to this problem is to set the keyring password to an empty string, by opening the Passwords and Keys app (type keyring into the search bar), and using the menu as below:

enter image description here

But is not a very good solution, because the keyring password keeps being reset, and you have to repeat the same process all over again. I am not sure if this happens on some reboots, or when there has been an update.

So my question is twofold:

  1. Am I correct in my thinking that the keyring passphrase doesn't add any security, and is redundant, since the system uses secure boot, with UEFI setting that doesn't allow boot from any other disk without an admin password, LUKS full disk encryption, and there are no other user accounts on the laptop?

  2. If (1) is correct, then how can I permanently remove the keyring password, in a way that it doesn't get added automatically again?

Edit

This question is related, but the answer doesn't offer a workaround: Why is my "no password" setting on my login keyring frequently reset?

Information requested in the comments

$ cat /etc/os-release
NAME="Ubuntu"
VERSION="20.04.3 LTS (Focal Fossa)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 20.04.3 LTS"
VERSION_ID="20.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=focal
UBUNTU_CODENAME=focal
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.3 LTS
Release:    20.04
Codename:   focal
$ echo $XDG_CURRENT_DESKTOP
ubuntu:GNOME
$ cat /usr/share/gnome/gnome-version.xml
<?xml version="1.0"?>
<gnome-version>
 <platform>3</platform>
 <minor>36</minor>
 <micro>8</micro>
 <distributor>Ubuntu</distributor>
 <!--<date></date>-->
</gnome-version>
5
  • Could you remember or dig into your history on how exactly did you manage your fingerprint reader to work? I need specific steps you took, I shall test the sequence if you provide any, and hopefully, we could find out an answer to your problem afterward. I have a fingerprint reader too, but I lack the info on how to make it work, I just use my password... If you used some wiki or guide on this, please provide it too. Jan 1, 2022 at 14:30
  • So I used your invite, verified my reader is not supported for the time being. So, I can't test anything, sorry. Jan 1, 2022 at 15:21
  • For anybody that wants to try this out, and doesn't have a working fingerprint sensor, I believe you can replicate this behavior by setting auto login as shown here help.ubuntu.com/stable/ubuntu-help/user-autologin.html.en
    – user000001
    Jan 4, 2022 at 9:55
  • This behavior also appears every time you change your login password (at the subsequent login). I don't know which password it is asking for and I don't care to guess. So every few months I end up on this odyssey to remember how to deal with this. My typical solution involves opening seahorse, logging in there, and deleting all the 'Passwords or Secret' entries that I never asked it to store in the first place. Apr 20, 2023 at 23:22
  • ...Here we go again (I guess it's been a "few months"). This popup is completely locking the entire desktop. I didn't realize this and ended up hard-rebooted my machine. It turns out that the desktop is non-responsive except for the fields and buttons in this dialog (you can't even move the dialog). I can't believe how bad this UX is (on Ubuntu MATE 22.04). The solution I should have applied (instead of rebooting) was just press Cancel (three times) -- but I wasn't able to figure that out in time. Related: askubuntu.com/questions/495957/… Nov 15, 2023 at 23:21

2 Answers 2

1

I tried the using a no-password for the fingerprint login and like you it re-set, so as I am using an encrypted disk anyway I set the password to something simple and then unlocked it on login by adding the following to the end of my .bash_profile file.

echo -n "somepass" | gnome-keyring-daemon –unlock

Seems to work fine so far.

-1

This is easy: just disable the password. setting your password to nothing (blank) will disable the prompt.

1
  • 1
    Yes, as I mentioned in the question, this works temporarily, but it the password gets reset after a while.
    – user000001
    Jan 6, 2022 at 6:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .