0

On a debian 11, with no desktops installed, how do you get network manager running for Awesomewm?

I have internet after I log into awesome, but it isn't through network manager, and even when I run the nm-applet, it doesn't even see my current connection (which is indeed working).

I'm looking for a guide on how to get Network Manager fully function on awesomewm to where the network manager service starts early enough to provide my base connection, and so that VPN configurations will work (as they currently do not).

4
  • 1
    NetworkManager is completely decoupled from your windowing system; it's a systemd system service, not a per-user thing. See systemctl status and observe how it's below system.slice. Dec 29, 2021 at 0:14
  • wait, you do get a user.slice, right? Dec 29, 2021 at 0:56
  • @MarcusMüller You're right that NetworkManager.service is subordinate to system.slice and I so see a user.slice before all that. But, I don't understand the ramifications of what you're trying to tell me. You see, up until now I've been spoiled by DEs, which set NetworkManager up for me. Now I'm trying to run AwesomeWM without any other DEs on the system and I'm a lost. I need a good tutorial on how to get NM up an running automatically, because that's the only way I know how to create VPN profiles. Although I set up a VPN profile with the nm_applet, I can't start the service. Dec 29, 2021 at 6:20
  • I'm reading this to gain some understanding. Dec 29, 2021 at 6:23

1 Answer 1

1

The default networking for Debian installations without a desktop environment uses ifup and ifdown from the ifupdown package for managing network connectivity. Having more than one network manager running can cause conflicts.

Remove ifupdown to use a different network manager:

# apt purge ifupdown

Remove ifupdown from NetworkManager's plugin list:

# sed -i 's/plugins=ifupdown,keyfile/plugins=keyfile/' /etc/NetworkManager/NetworkManager.conf

Enable NetworkManager's service:

# systemctl enable NetworkManager.service

Reboot and you should have network connectivity established by NetworkManager if you are using Ethernet. If not, connections can be created with nm-applet, nmtui or nmcli.

Run nmcli to verify that your interface is connected. Expected output:

<interface>: connected to <connection name>

It should not say: <interface>: unmanaged

If NetworkManager is still not working, you may want to check for any other network managers that are running and remove / disable them. Another common one is systemd-networkd, which can be disabled through its service systemd-networkd.service.

2
  • I got both of my ethernet ports working through Network-Manger in Awesome, but one of the ports will only connect at 100mb half duplex, while the other one connects at gigabit full duplex. I've documented my experience here. If you have any idea why I wouldn't be getting gigabit full duplex on both ports, please advise here. Jan 3, 2022 at 3:02
  • 1
    Unfortunately, I have no idea why that would be happening. Have you looked at this as a possible solution?
    – Snake
    Jan 3, 2022 at 5:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .