0

I am trying to install zabbix-agent2 as mentioned in this link agent 2 is available in pre-compiled Zabbix packages.

I ran

rpm -Uvh https://repo.zabbix.com/zabbix/5.4/rhel/8/x86_64/zabbix-release-5.4-1.el8.noarch.rpm

Then search for Zabbix-agent2 using yum and it shows available. However, when I try to install using

Sudo yum install zabbix-agent2

It shows Error: Package: zabbix-agent2-5.4.9-1.el8.x86_64 (zabbix) Requires: libc.so.6(GLIBC_2.28)(64bit)

How can I resolve this? Is there any alternative way to install it?

0

1 Answer 1

1

Amazon Linux 2 is based on RHEL 7 and is still using glibc 2.26. You are installing the package from the Zabbix repo that is based on RHEL 8 which requires glibc 2.28 which is more recent. You can't upgrade glibc because the basic functionality of the OS depends on a specific version.

What you need to do instead is to use the Zabbix repo that is based on RHEL 7 and install zabbix-agent2 from there:

yum install https://repo.zabbix.com/zabbix/5.4/rhel/7/x86_64/zabbix-release-5.4-1.el7.noarch.rpm

yum install zabbix-agent2

You can also use rpm -Uvh to install the rpm for the repo in the first step but it makes no difference.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .