1

I have an HP Pavilion-15 laptop with Linux Mint and Windows in dual boot config and have been having bluetooth issues for a long while. Off-late my PC has been unable to detect any Bluetooth adapter at all. I have tried everything, looked into multiple forums, but no avail.

A screengrab of blueman after I click on Adapters option is shown here:

screengrab

I uninstalled and reinstalled bluez, installed blueman, but to no avail. Some of the outputs of the things I tried are below:

  • hcitool dev gives no bluetooth device. Neither do any other hci commands.

  • bluetoothctl outputs are here:

    Agent registered
    [bluetooth]# show
    No default controller available
    [bluetooth]# 
    
  • rfkill does not list bluetooth

  • systemctl bluetooth status output

    bluetooth.service - Bluetooth service
    Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset
    Active: active (running) since Mon 2021-12-27 16:03:21 IST; 4h 30min ago
    Docs: man:bluetoothd(8)
    Main PID: 3411 (bluetoothd)
    Status: "Running"
     Tasks: 1 (limit: 4915)
    CGroup: /system.slice/bluetooth.service
            └─3411 /usr/lib/bluetooth/bluetoothd
    
    Dec 27 16:03:21 prabodh-HP-Pavilion-Laptop-15-cs1xxx systemd[1]: Starting Blueto
    Dec 27 16:03:21 prabodh-HP-Pavilion-Laptop-15-cs1xxx bluetoothd[3411]: Bluetooth
    Dec 27 16:03:21 prabodh-HP-Pavilion-Laptop-15-cs1xxx systemd[1]: Started Bluetoo
    Dec 27 16:03:21 prabodh-HP-Pavilion-Laptop-15-cs1xxx bluetoothd[3411]: Starting 
    Dec 27 16:03:21 prabodh-HP-Pavilion-Laptop-15-cs1xxx bluetoothd[3411]: Bluetooth
    

I did a Bluetooth service restart using systemctl, did not work.

  • sudo lsmod | grep blue output:

    bluetooth             544768  10 btrtl,btintel,btbcm,bnep
    ecdh_generic           16384  1 bluetooth
    
  • dmesg | grep -i blue output

    [   18.846174] Bluetooth: Core ver 2.22
    [   18.846203] Bluetooth: HCI device and connection manager initialized
    [   18.846205] Bluetooth: HCI socket layer initialized
    [   18.846206] Bluetooth: L2CAP socket layer initialized
    [   18.846208] Bluetooth: SCO socket layer initialized
    [  115.866301] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [  115.866303] Bluetooth: BNEP filters: protocol multicast
    [  115.866309] Bluetooth: BNEP socket layer initialized
    [  384.520506] audit: type=1400 audit(1640601469.856:29): apparmor="STATUS"    operation="profile_load" profile="unconfined" name="snap-update-ns.bluetooth-autostart" pid=5349 comm="apparmor_parser"
    [  384.577833] audit: type=1400 audit(1640601469.912:30): apparmor="STATUS" operation="profile_load" profile="unconfined" name="snap.bluetooth-autostart.autostart-bluetooth" pid=5350 comm="apparmor_parser"
    [  401.660520] audit: type=1400 audit(1640601486.984:33): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="snap.bluetooth-autostart.autostart-bluetooth" pid=5386 comm="apparmor_parser"
    [  401.662906] audit: type=1400 audit(1640601486.988:34): apparmor="STATUS" operation="profile_replace" info="same as current profile, skipping" profile="unconfined" name="snap-update-ns.bluetooth-autostart" pid=5388 comm="apparmor_parser"
    [  410.729139] audit: type=1400 audit(1640601496.048:35): apparmor="DENIED" operation="create" profile="snap.bluetooth-autostart.autostart-bluetooth" pid=5413 comm="hciconfig" family="bluetooth" sock_type="raw" protocol=1 requested_mask="create" denied_mask="create"
    

    Note: I installed bluetooth-autostart snap after trying a lot of other things. Before that, the dmesg output was whatever is in the snippet above apart from the snap related messages.

  • The output of lscpi does not seem to list a bluetooth i/f

    00:00.0 Host bridge: Intel Corporation Device 3e34 (rev 0b)
    00:02.0 VGA compatible controller: Intel Corporation Device 3ea0
    00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th    Gen Core Processor Thermal Subsystem (rev 0b)
    00:12.0 Signal processing controller: Intel Corporation Device 9df9 (rev 30)
    00:14.0 USB controller: Intel Corporation Device 9ded (rev 30)
    00:14.2 RAM memory: Intel Corporation Device 9def (rev 30)
    00:14.3 Network controller: Intel Corporation Device 9df0 (rev 30)
    00:16.0 Communication controller: Intel Corporation Device 9de0 (rev 30)
    00:17.0 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 30)
    00:19.0 Serial bus controller [0c80]: Intel Corporation Device 9dc5 (rev 30)
    00:1c.0 PCI bridge: Intel Corporation Device 9db8 (rev f0)
    00:1c.4 PCI bridge: Intel Corporation Device 9dbc (rev f0)
    00:1d.0 PCI bridge: Intel Corporation Device 9db0 (rev f0)
    00:1d.1 PCI bridge: Intel Corporation Device 9db1 (rev f0)
    00:1f.0 ISA bridge: Intel Corporation Device 9d84 (rev 30)
    00:1f.3 Audio device: Intel Corporation Device 9dc8 (rev 30)
    00:1f.4 SMBus: Intel Corporation Device 9da3 (rev 30)
    00:1f.5 Serial bus controller [0c80]: Intel Corporation Device 9da4 (rev 30)
    02:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev a1)
    04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
    
  • On Windows, I am able to detect and connect the bluetooth devices normally. in fact, I have a feeling that the issues started after I booted into Windows once. I disabled fast boot on windows and did a cold restart. Did not resolve.

I am at the end of my rope here. Please suggest something to resolve this issue. Thank You.

2 Answers 2

0

I see that the module btusb is not showing in the lsmod. Try sudo modprobe btusb

-1

try this: sudo systemctl enable bluetooth.service (make sure you have installed bluetooth package)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .