2

I'm following a tutorial on how to install firmware on OpenBSD. The tutorial has me creating a new msdos file system on the usb with: newfs_msdos -F 32 /dev/rsd2c then to take usb to a system with an internet connection, then move the firmware tarball into the USB. I have never moved data to a msdos fs via the command line before. The tutorial shows him using dolphin on a manajaro install, however I do not have any systems with gui's installed.

How can I move the tarball to the usb drive?

I've tried mounting it them moving to the mounted directory but it does not work.

Stating failed to preserve ownership for '/mnt2/iwn-firmwae.tgz': Operation not permitted

Here's a link to the tutorial: https://www.youtube.com/watch?v=kUrUq2qfWiY

6
  • There is no "msdos" filesystem, what they refer to as "msdos" is the partition table. You still need to create the partitions before you can mount the drive. In any event, please link the tutorial you followed, as there seem to be quite a bit of confusion and misunderstandings going on.
    – polemon
    Commented Dec 23, 2021 at 23:56
  • @polemon I added the link Commented Dec 23, 2021 at 23:59
  • OK, you need to watch the tutorial further. He shows at 3:03 how to mount the FS he partitioned at. In fact this tutorial is pretty bad, as he failed to explain that what he created on the USB drive is a FAT32 filesystem. Also, don't use mv use cp if you haven't done so. You can use the option --no-preserve to select attributes which should not be preserved, like cp --no-preserve=mode.
    – polemon
    Commented Dec 24, 2021 at 0:10
  • The FAT32 filesystem doesn't support unix permissions, so any attempt to set perms will result in an error. Did you check to see if the tar file was actually moved to the USB stick? My bet is that the mv succeeded, and the error message is only about the failure to set the file's perms after it was moved (that's how it works on Linux with GNU mv -- OpenBSD's implementation of mv may behave differently, like trying to set perms before the mv has completed. dunno). Also, as @polemon says, probably best to use cp rather than mv. You can always delete the original afterwards if needed.
    – cas
    Commented Dec 24, 2021 at 0:44
  • 1
    mv first moves the file, then it tries to set the permissions to what they were before it was moved. the first action works, the second fails (because FAT32 doesn't support unix file permissions)
    – cas
    Commented Dec 24, 2021 at 1:29

1 Answer 1

5

The message

failed to preserve ownership for '/mnt2/iwn-firmwae.tgz': Operation not permitted

is more of a warning than an error. The files copied successfully, but permissions and ownership of the files were not copied.

Most likely this is a DOS filesystem which does not support unix ownership and permissions. For the purposes you describe, permissions and ownership are not important, so you can safely ignore this message as a warning.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .