2

I am having trouble accessing a Oracle Linux 8 VM in Oracle Cloud, following a kernel update yesterday. I need help in knowing how to resolve the issue, or even if I should try. (The alternate being delete the VM and re-create it using the last boot volume backup, which does lose some data but not a huge amount).

What happened: I ran dnf upgrade and it installed a new kernel. Thereafter I restarted. After restart I was unable to connect via SSH anymore, receiving error 1005 (connection refused). I used the Oracle Cloud console to restart the VM, with the same result. Thereafter I decide to try connecting to troubleshoot with Oracle Cloud Shell, thinking maybe the ssh service was down or maybe the firewall had start blocking port 22 somehow. But instead it shows the VM is still in the boot process stuck at "A start job is running for /etc/rc...ompatibility" (screenshot below).

enter image description here

I allowed this to run for 24 hours to see if it would move past it but it does not. I've tried a couple restarts. I would like to do something in the Cloud Shell to to resolve this but it doesn't seem I can even type anything at this point.

I consulted this answer but it appears I would have had to enable the debug shell before the issue. This one looks promising but of course is for another distro. Is there anything similar for Oracle Linux (or CentOS/RHEL etc) that could work? Any other way to resolve?

Or is it just better for me to re-create a new VM using the last boot volume backup? It'll lose me some data but that's ok...just don't want to re-create the issue again with a future kernel update.

PS: I am fairly new to Linux cli and Linux in general so I apologize if this is all rookie stuff...frankly I was tempted to just re-create the VM using the backup but figure I need to learn how this happened and to fix it if I can, to help for the future.

1 Answer 1

3

I asked the answer to two questions.

  1. Is it worth it to try and fix this or should I nuke the VM and re-create from the last boot volume back? (losing some work and at fear issue will re-occur)
  2. If it is worth it to fix (not time intensive and will save me data lose), how?

I will now provide my own answer to the fist question. After many hours of research, and no quick answer here, I believe fixing this to be time intensive. Furthermore I cannot afford the time to wait until I can get it fixed. Thus my answer is "no" it is not worth it. Therefore I will nuke the VM and re-create from the last backup, then re-create the work I lost.

That answer to the first question makes the second question moot. Although I hope to eventually learn and also this does not reoccur.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .