6

When I open Google Chrome (Stable version), I see the following dialog box:

Your profile could not be opened correctly. Some features may be unavailable. Please check that the profile exists and you have permission to read and write its contents

I know for sure this problem happened only on Linux (Fedora 18) because when I use my Chrome profile in Windows, nothing goes wrong.

Also, I always get a bug report about google-chrome-stable version (I always update the system and Chrome too).

How do I resolve this problem without losing any data in my profile?

2

I've encountered this error several times and here is the way how i fixed it:

  1. Close Chrome.
  2. Delete the file named Web Data in ~/.config/google-chrome/Default.
  3. Start Chrome again and everything should be fine.
1

Just removed rm -rf Web\ Data from ~/.config/chromium/Default.

  • had to restart computer.
1

For me the solution was to look for chrome zombie processes. I've killed all of them and then chrome started to work ok again.

0

Try re-owning your files.
sudo chown -R username:username /home/username

This should not mess up anything (as files in your home should be owned by your own user). By the way... Chrome gave me this error when I downgraded. (I had to delete my profile and use sync.)

0

I ran into the same problem on my Fedora system, but the problem was not actually caused by incorrect permissions.

My /tmp drive was completely full (with Google Chrome tempfiles, no less!), so there was no room for Chrome to create a new temp directory to do whatever it needed to do to load my profile!

The following command fixed the problem (you shouldn't need to sudo this command unless multiple users on your system have launched the google-chrome app):

rm -rf /tmp/.com.google.Chrome.*
0

This post has a discussion about this issue. And the reply from kyron works for me: https://productforums.google.com/forum/#!msg/chrome/IoQgoKuGh2E/2iJNqAnJ4bgJ

0

I know this is an old question, but....

None of the solutions about deleting Web Data, create new profiles, etc worked for me on my CentOS 7 box. Here's what did work:

sudo setsebool -P unconfined_chrome_sandbox_transition off

I've submitted a bug to Google because I shouldn't have to disable that boolean to get Chrome to work.

0

That did it for me on Fedora 22:

  • Shut down Chrome
  • mv ~/.config/google-chrome/Default /tmp
  • mv /tmp ~/.config/google-chrome

Not data lost

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.