So I just tried to install archlinux a bunch of time without being able to boot to it, I searched my problem and found a lot of people having the same problem and I tried a bunch of things but unfortunately I didn't succeed. Asking about my problem here is my last resort so I hope somebody can help me and I hope I learn a thing or two after solving my problem.
(sorry for my bad english).
So I'll start with sharing the steps I did to install archLinux:

  1. Boot up the live system with usb drive

  2. Verify that I'm booted in EFI mode with this command ls /sys/firmware/efi/efivars (this gives me a bunch of gibberish which means I'm in efi mode as said in arch's official installation guide)

  3. Partitioning the disk with fdisk /dev/nvme0n1:

    • Create a GPT partition table with option g
    • 512M: EFI partition----->(/dev/nvme0n1p1)
    • 4G: swap partition------>(/dev/nvme0n1p2)
    • rest: root partition------->(/dev/nvme0n1p3)
    • writing changes to disk
  4. formatting created partitions with the following commands:

    • mkfs.fat -F32 /dev/nvme0n1p1
    • mkswap /dev/nvme0n1p2
    • mkfs.ext4 /dev/nvme0n1p3
  5. Mount the partitions:

    • mount /dev/nvme0n1p3 /mnt
    • swapon /dev/nvme0n1p2
  6. Install essential packages on /mnt: pacstrap /mnt base linux linux-firmware

  7. Generate fstab file: genfstab -U /mnt >> /mnt/etc/fstab

  8. Chroot into /mnt: arch-chroot /mnt

  9. Generate initramfs: mkinitcpio -P

  10. Installing grub and some other packages: pacman -S grub efibootmgr os-prober base-devel mtools dosfstools...

  11. Create EFI boot directory and mount it: mkdir /boot/EFI && mount /dev/nvme0n1p1 /boot/EFI

  12. Install Grub bootloader: grub-install --target=x86_64-efi --bootloader-id=grub_uefi --recheck

  13. Generate Grub Config: grub-mkconfig -o /boot/grub/grub.cfg

  14. Exit chroot, Unmount partitions umount -a, reboot

! All commands were prompted successfully without an error

Note: some steps are skipped like setting timezone, hostname, hosts, adding user etc.

after reboot arch doesn't boot up and the uefi menu has only enter setup which will get me to the bios.

Am I missing something here??? or am I doing something wrongggg??? Help Please!!!

andddd thanks in advanceee <3


I reinstalled grub bootloader and regenerated the grub Configuration with the same commands in steps 12 and 13

before rebooting my computer the output of efibootmgr -v is

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0000,0001
Boot0000* grub_uefi HD(1,GPT,d20bff6e-6f1e-c549-9f1b-505a302fd42c,0x800,0x100000)/File(\EFI\grub_uefi\grubx64.efi)
Boot0001* UEFI: Generic Flash Disk 8.07, Partition 1 ...Gibberish..BO

but After reboot the output is:

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001
Boot0001* UEFI: Generic Flash Disk 8.07, Partition 1 ...Gibberish..BO
  • Can you see the EFI entry for "Arch" in your BIOS settings? (From the live USB) what does efibootmgr show? Dec 20, 2021 at 21:11
  • Please edit your question and post the output of efibootmgr -v after running modprobe efivars. Maybe check if Arch has an entry in your BIOS. Dec 20, 2021 at 21:26
  • @ajgringo619 I already mentioned that the only output in the EFI entry is Enter Setup which will get me into the bios if I click it.
    – AzerSD
    Dec 21, 2021 at 8:20
  • @ArtemS.Tashkinov thanks for your feedback. question edited.
    – AzerSD
    Dec 21, 2021 at 8:20
  • 1
    @TomYan - You should post that as an answer Dec 21, 2021 at 9:53

1 Answer 1


I think that you just forget efi_directory folder to grub configuration file

try this:

grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub 

You don't need to reinstall you system just re-mount the system and run arch-chroot /mnt and generate grub configuration again. Remember to also run

grub-mkconfig -o /boot/grub/grub.cfg

Another thing on step 11:

Create EFI boot directory and mount it: mkdir /boot/EFI && mount /dev/nvme0n1p1 /boot/EFI

You have to do this part before generate fstab so you system needs to boot properly...

Give us some feedback if it helped. grub has changed some configuration directly on kernel and don't use os-prober by default anymore (if you are trying to run a dual boot system)

  • unfortentaly that didn't change anything. and no I'm not trying to run a dual boot system I had windows 11 but now I'm totally switching to arch. I edited my question you can check it again. thanks for your try <3
    – AzerSD
    Dec 21, 2021 at 8:22
  • The ESP was NOT used for /boot in his setup / procedures btw.
    – Tom Yan
    Dec 21, 2021 at 9:32
  • What about fstab? @TomYan I've done with ESP and worked fine, I think grub changed to work without ESP, but you can use btw Dec 21, 2021 at 14:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .