0

I'm running Ubuntu 20.04 Server with Kernel 5.11 including built in exfat support - I don't have exfat-fuse or exfat-utilities and would prefer to just use the new native kernel support.

I'm able to see and mount the exFat drive - and have a working fstab config - but I'm struggling to make the drive mount with 0770 permissions. Here's my working fstab line for the drive:

UUID=MY-ID-HERE /mnt/storage exfat defaults,nofail,gid=998 0 0

This mounts the drive with root as the owner, docker as the group and 0755 perms - I'd like to mount the drive with 0770 permissions (or even 0775) so that any member of the docker group can write to the drive.

I attempted to set the perms with:

UUID=MY-ID-HERE /mnt/storage exfat defaults,nofail,gid=998,file_mode=0770,dir_mode=0770 0 0

But get this error when running sudo mount -a:

mount: /mnt/storage: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error.

I know I can't chmod/chown an exfat drive - but it looks like the OS is inferring a default set of perms when it mounts the drive and I'm wondering if there's a way to modify those default perms?

1 Answer 1

1

Typical - found the answer within minutes of posting the question. I can't use file_mode or dir_mode but I can use umask - working line for 0770 perms is:

UUID=MY-ID-HERE /mnt/storage exfat defaults,nofail,gid=998,umask=007 0 0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .