2

Yesterday I duplicated my Windows 10 machine in Gnome boxes to upgrade to Win 11. After realising that it would need 64 GB of space on my harddrive, which I do not have currently, I deleted the image.

Now Gnome boxes crashes with the following error:

(gnome-boxes:59538): Boxes-CRITICAL **: 09:44:24.321: boxes_vm_importer_get_source_media: assertion 'self != NULL' failed

To me this sounds like a missing image (source_media).

I would like to simply delete the machine that is referring to that image, but googling didn’t provide me with anything useful.

Thanks for help

1 Answer 1

3

So I found the answer.

Gnome boxes itself does not manage VMs itself, but uses libvirt, which has a powerful command line interface (CLI) in the virsh tool.

It was not installed on my system yet.

You can list all your defined machines with virsh list --all.

The command to “delete” a VM is undefine.

virsh undefine win11 worked for me, and Gnome boxes is starting again.

3
  • 1
    in all honesty, gnome-boxes falls prey to the (very GNOME-typical) "make the not-so-simple simple" trap: It really tries to make thing simple, which is great; at the same time, it hasn't reached the maturity that makes such problems impossible to happen, and then you left without an indication or chance to resolve things within gnome-boxes itself. That's why I stayed with virt-manager as a libvirt GUI. Commented Dec 16, 2021 at 11:28
  • 1
    That's a good analysis. Seems like GNOME needs a lot of back-end improvements to get apps more robust, as Gui is already quite nice and easy to use
    – Andy
    Commented Dec 17, 2021 at 19:52
  • 1
    Indeed, I liked it so much, it moved into my "likely to recommend to my dad" list, until I worked with it and it broke in multiple places. (the other, never-ceases-to-disappoint thing is gnome-shell; honestly, talked to a redhat guy, one of the motivations for them to push for cgroups2 for desktop application resource isolation was to make sure a misbehaving gnome-shell didn't take down the system as likely; in the same talk he said they're still figuring out how to fix gnome-shell... priorities, I guess.) Commented Dec 17, 2021 at 22:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .