1

Previously(successfully), I had updated my SSL certificates in the same fashion as I tried to do this time. Like 2 files I have, domain.chained.crt and domain.key.

Then ran sudo service nginx restart, sudo service nginx reload and sudo nginx -s reload commands, the Nginx is still serving the old certificate. On Firefox when I click View Certificate it is showing an old one.

enter image description here

After that, I even changed the file name to mydomain.chained1.crt and mydomain1.key, then I also change the file names in nginx.conf like

ssl_certificate ssl/mydomain.chained1.crt;
ssl_certificate_key ssl/mydomain1.key;

After the changes, restarting and reloading nginx doesn't change the SSL certificate.

How can I solve this issue?

2
  • It's far more likely that Firefox is caching the certificate. Try in incognito mode or try a different browser. Dec 14, 2021 at 19:28
  • I tried it on chrome and firefox, both in incognito modes, but same result.
    – Junaid S.
    Dec 14, 2021 at 19:38

1 Answer 1

0

You have to upload the latest certificate pem, chained, and key files on CloudFront too in the respective domain.

So the steps will be goto CloudFront -> Certificates. Select the desired domain then click on Re-Import.

Then put the latest pem, chained(optional), and key files.

So in total, in your case, 2 places where you have to update the certificates, which are Nginx and CloudFront. If you've got the certificate from AWS then you don't have to worry about CloudFront, because it auto-renews and auto-update.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .