After I switching from Debian 10 to 11, LibreOffice Draw 7.0 can no longer open.

I tried opening an existing file and starting a new file, no matter how I open Draw, it crashes with this message:

Due to an error, LibreOffice crashed. All the files you were working on will now be saved.
Next time the LibreOffice is launched, your files will be recovered automatically.

If I open an existing file, or try to create a new one, it crashes, then immediately tries to pull up a document recovery for the blank file, then crashes again, no matter which open I choose.

Please ensure that a JVM and the package libreoffice-java-common
is installed.
If it is already installed then try removing ~/.config/libreoffice/4/user/config/javasettings_Linux_*.xml
Warning: failed to read path from javaldx

(soffice:4787): dbind-WARNING **: 14:29:52.992: AT-SPI: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
  • The errors above appear on another Debian computer where Draw does work, so I think these have nothing to do with the error.

I tried several things:

  • Tried purging the entire LibreOffice install, and reinstalling.
  • Tried deleting the .config files related to LibreOffice.
  • Tried running in command line, but there are no messages shown related to its crashing.
  • Tried running in Safe Mode, no change.
  • Installed libreoffice-gtk3 (some said it crashes without this installed).
  • LibreOffice Write and Calc work fine.

How can I fix LibreOffice Draw from crashing?


journalctl reports this every time I try to open Draw, but not when opening a tool that does work, like Write:

Jul 08 15:35:20 debian audit[2833]: AVC apparmor="ALLOWED" operation="open" profile="libreoffice-soffice" name="/home/village/Projects/Textbooks/Popups/Core/2022-07-05_glossary.data" pid=2833 comm="soffice.bin" requested_mask="r" denied_mask="r" fsuid=1000 ouid=1000
Jul 08 15:35:20 debian kernel: audit: type=1400 audit(1657316120.083:15): apparmor="ALLOWED" operation="open"

Update: I found if I run libreoffce --norestore to disable crash handling, it prints this error:

Fatal exception: Signal 6


  • 1
    If you run it from the command line: libreoffice existing_file you might find more information on the crash. You can add that output to your question. Commented Dec 12, 2021 at 4:47
  • It isn't printing any new errors, only complains about missing Java, but I've used LibreOffice for 20 years and ignored that error for as many years, having never had a need for Java to be installed.
    – Village
    Commented Dec 12, 2021 at 13:53
  • Try GDK_BACKEND=x11 QT_QPA_PLATFORM=xcb libreoffice & disown from a terminal window.
    – anick
    Commented Jul 7, 2022 at 20:22
  • @anick Tried, didn't seem to do anything differet, Draw still crashes.
    – Village
    Commented Jul 7, 2022 at 20:31
  • 4
    Can you create a new user and see if it works with the new user? Commented Jul 9, 2022 at 0:34

4 Answers 4


I will write some possible solutions, because it is to long for a comment.

  1. Try to reinstall and install again
apt purge libreoffice*
apt autoremove
apt install libreoffice
  1. Stop apparmor and run draw again

  2. There are some problems with wayland and a view programms in debian 11

  • can you try to run a second desktop like kde, cinnamon, etc.. and ran draw
  • if you switch from x11 to wayland can you try to install both together and try to run once with x11 and once with wayland and see if the problem exists in both or in one of them
  1. check again all packages, their connections and dependents which are needed for LibreOffice to run and fix, reinstall them

  2. there are some problems too with gdm3, lightdm and sddm in debian 11 with wayland and x11

  3. I think to remember that there were still a few problems with the non-free and some backports packages

In the company we still work with debian 10.9 because we had some problems with debian 11 ourselves at the beginning in the past, but that's just only my opinion!


Fatal exception: Signal 6

Looks like there is the problem with the packages.

Check this for dependent packages:

How to list dependent packages (reverse dependencies)?

apt-rdepends on Debian 11 (Bullseye)

Paket: apt-rdepends (1.3.0-7) | recursively lists package dependencies

Check this for Fatal exception: Signal 6:

libreoffice on arm64, terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException' \ Fatal exception: Signal 6

Fatal exception: Signal 6

LibreOffice 7.3.2 keeps dumping core

Writer suddenly crashes at the time or shortly after a document has loaded

Dependency on libreoffice-nlpsolver should be tighter

If this won't fit with, update, upgrade, downgrade, fix, clear of the packages, than try nr.3 with the desktops and nr. 5 if possible.

I would first use only this sources for packages in /etc/apt/sources.list on a fresh install of debian 11 for update & upgrade

deb http://deb.debian.org/debian bullseye main
deb-src http://deb.debian.org/debian bullseye main

deb http://deb.debian.org/debian-security/ bullseye-security main
deb-src http://deb.debian.org/debian-security/ bullseye-security main

deb http://deb.debian.org/debian bullseye-updates main
deb-src http://deb.debian.org/debian bullseye-updates main

Even after completely reformatting my computer's hard drives, making new install media, and installing the latest version of Debian Bullseye, I continued to have this problem.

After considerable trial and error, I found the crashing stopped after I installed libreoffice-impress.

  • Same thing on Ubuntu 22.04. Impress only took an extra 10MB.
    – kontextify
    Commented Jun 27, 2023 at 9:34

You can install the essential distro LibreOffice packages in this way:

$ sudo apt install libreoffice

But, I suggest that you install the latest version of LibreOffice from its website, libreoffice.org.

This is the download page, in which you can download LibreOffice 7.4 as a set of .deb files that you can easily install:


Then, extract the downloaded package with:

$ tar zxf LibO_*.tar.gz

And then install the .deb files:

$ cd LibO_*/DEBS
$ sudo dpkg -i *.deb

Edit: clarity & comment(s)

Fixing Udev issue

To fix the udev issue, which is not connected to the, Draw crashes you have to install sudo apt-get install at-spi2-core.

LO Draw crashing

Now to your core issue. Due to your actions it is pretty safe to say that it is either your configuration or LO Draw bug (or combination of those).

The apparmor line:

Jul 08 15:35:20 debian audit[2833]: AVC apparmor="ALLOWED" operation="open" profile="libreoffice-soffice" name="/home/village/Projects/Textbooks/Popups/Core/2022-07-05_glossary.data" pid=2833 comm="soffice.bin" requested_mask="r" denied_mask="r" fsuid=1000 ouid=1000

Tells you that the apparmor allowed the operation open the"/home/village/Projects/Textbooks/Popups/Core/2022-07-05_glossary.data" file (to make sure it has nothing to do with the apparmor you can temporarily stop it for the test purposes with - sudo systemctl stop apparmor).

I would do the following:

  1. Check the file rights, adjust them with chmod or chown if needed, for your login for the file at location:


  1. Check the file itself for inconsistencies

  2. Check your ~/.profile, ~/.bash_profile or ~/.bash_login for any mistakes. For example, pointing to wrong file.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .