1

If I choose to have a module built-in (Y), I can choose "e" to edit the boot entries on GRUB2 and modify the kernel command line to include "module.variable=whatever" and it works fine. However, if I change the build configuration to have the module be a module (M) then passing the variable on the kernel command line doesn't work.

The question is, how do I boot to GRUB2 and then set a parameter for the loadable module so that when booted the parameter is set for the module? This is needed for a portable boot disk that sometimes won't boot up properly on certain systems without changing the loadable module parameter. I was hoping the module.var=n method was global in that whatever loads the module could find the name "module." and use the when loading the module passing the data after the ".". It says modprobe should do that, but in my case it's not.

Thanks.

Update: I think I know what's going on, the module is loaded via modprobe but there is another built-in module which must get processed before the one loaded by modprobe which pulls in the device for itself so the parameter is set but the module is never called for the given device. back to the drawing board.

2
  • the I was hoping ..... after the ".". is just irrelevant clutter in your post ... you already said that it does not work ... otherwise, a good question ... upvote
    – jsotola
    Dec 12, 2021 at 1:07
  • Have you adjusted grub.cfg? For Debian, you can also make the change in /etc/default/grub, update-grub will then consider the parameter.
    – Hermann
    Dec 12, 2021 at 2:39

0

You must log in to answer this question.

Browse other questions tagged .