1

I don't know what I did and if it was my fault. But for two days my touchpad does not work anymore.

Facts:

  • I have no xorg.conf.
  • Ubuntu system settings (gnome-control-center) don't show the mousepad.
  • gconf-tool says touchpad is enabled.
  • xinput list says touchpad is enabled. (SynPS/2 Synaptics TouchPad)
  • In Windows it works so no hardware problem here.
  • I use awesome, but in unity it does not work too.
  • New: Tap for a mouseclick click works!!

I don't know if I had an xorg.conf before. Awesome WM worked with the pad before. But I read something about lightdm-session or gnome-session-manager disabling the pad. These are two tools I played around with because awesome starts none of them. Any approaches to solve this?

My pad works again. And I don't know why!!!!

closed as off-topic by Jeff Schaller, Anthon, don_crissti, Stephen Rauch, Hauke Laging Oct 8 '17 at 16:08

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Anthon, don_crissti, Stephen Rauch, Hauke Laging
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you tried this in "reverse"? unix.stackexchange.com/a/20235/18110 – Erik Mar 15 '13 at 20:44
  • Device 'SynPS/2 Synaptics TouchPad': Device Enabled (133): 1 ... well, thanks anyway – ManuelSchneid3r Mar 15 '13 at 20:52
  • Could it be settings like very low sensitivity, bogus region definition or palmdetect settings, What's the output of synclient? – Stéphane Chazelas Mar 15 '13 at 22:54
0

I have exactly the same issue here (but tapping doesn't work, but touchpad buttons works fine).

my synclient says:

Couldn't find synaptics properties. No synaptics driver loaded?

and

xinput list-props "ETPS/2 Elantech Touchpad"
Device 'ETPS/2 Elantech Touchpad':
    Device Enabled (135):   1

I also use awesome, but on unity it doesn't work as well.

But this helped in my case:

$ sudo apt-get install xserver-xorg-input-multitouch
$ sudo apt-get install xserver-xorg-input-synpatics
$ sudo reboot
  • I think that the package name is xserver-xorg-input-synaptics – Diogo Moreira Apr 19 '16 at 16:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.