I wanted to use btrfs on my Linux Mint PC more, but I keep encountering new issues. Now I've found out (tried on two USB sticks) that btrfs formatted USB stick can be properly unmounted/ejected via GUI (Nemo), but not from terminal.

$ umount /dev/sdb1
Error finding object for block device 0:87

For other fs it works, just checked that after I insert USB stick and it is automounted, running umount in terminal works (for ext4 and ISO 9660), but not for btrfs.


Sticks were formatted with btrfs via Gnome-disks, maybe it matters...

Added 1:
Btrfs partition on local harddrive mounted via Gnome-Disks GUI produced same error on umount in terminal. I was able to successfully sudo mount and sudo umount it in terminal.

Added 2:
sudo umount works and does not produce the error.

  • For me I find the device to be in a state where sudo umount gives "target is busy". This is reported even if the plasma desktop device widget reports the device as already unmounted (however the mount command reports it as still mounted (how can the plasma widget pretend it is unmounted). Even after pulling the USB cable, the mount command still lists it as mounted. Possibly the reason is that a "fusermount" process still accesses the /dev/sdb.
    – StefanQ
    Apr 13, 2022 at 14:45
  • Same issue here, under pretty outdated Fedora 27 and under openSUSE Tumbleweed. USB stick created with fdisk followed by mkfs.btrfs. The mount command entry on the USB stick is /dev/sdc1 on /run/media/luke/Data type btrfs (rw,nosuid,nodev,relatime,seclabel,space_cache,subvolid=5,subvol=/,uhelper=udisks2). sudo umount works fine. May 4, 2022 at 18:50

1 Answer 1


With udisksctl

I had the same issue on Arch Linux 5.18.15 where udiskie auto-mounted a Btrfs partition created with btrfs-progs v5.18.1.

What worked for me was

udisksctl unmount --block-device /dev/sdb1

which doesn't need root privileges.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .