0

I have a pretty special problem for which I can't find the solution. So let's begin.

I had two OSes running in parallel. One Ubuntu 20.04 for work and one for Windows 10 and private usage. I installed the Ubuntu partition after Windows so configuring GRUB for that was quite easy.

Now I installed another Hard drive with yet another Windows 10 on it for another Job I just took and everything got mixed up.

For an overview I have three hard drives with three distinct OSes.

  • sda
    • Ubuntu 20.04 for work. The root partition is encrypted, so I have a seperate boot partition on it
  • sdc
    • Windows 10 for privat usage.
  • nvme0n1
    • Windows 10 for second job

So by installing the second Windows 10 on nvme0n1 the Windows installer seemed to overwrite the boot partition on sda. The only thing I could boot was now the windows boot manager which only showed both windows installations. So I booted from a Ubuntu live stick and tried to reinstall grub2. That already took me ages. I removed the boot partition, mounted the encrypted root partition from sda and with going into the chroot environment I was able to reinstall GRUB so that I was able to boot again into Ubuntu 20.04. But NOW I am not able to Boot to the Windows Partitions. They were not listed in the GRUB Boot menu and stuff like

sudo os-prober

sudo update-grub

were not able to find the windows installations. When I try to choose one of the hard drives directly as boot medium in the bios it shows that there is no Operating system installed. So I think that by deleting the Windows Boot manager Partition I also lost every information about the windows installation. I already saw that there are ways to reinstall the Windows Boot manager from the Windows Installation but I am afraid that it will only overwrite again the boot partition on sda and I end up where I started in the first place.

I also tried to manually integrate the Windows Boot entries into /etc/grub.d/40_custom which looks like that:

menuentry "Windows 10 - Job" --class windows --class os {
           insmod ntfs
           search --no-floppy --set=root --fs-uuid 3600AB6100AB2739 
           ntldr /bootmgr
}
menuentry "Windows 10 - Home" --class windows --class os {
           insmod ntfs
           search --no-floppy --set=root --fs-uuid 84EC4785EC47710A 
           ntldr /bootmgr
}

The entries show up in the GRUB Menu but unfortunatly I get the error grub invalid efi file path. So, I don't know what to do next...

2
  • Can you verify that the UEFI/BIOS settings for SATA if it's an Intel CPU are set as AHCI and not as RAID? Sometimes this prevents detection of nvme drives when not using Windows (but changing the setting usually renders an already installed Windows non-working).
    – A.B
    Dec 8, 2021 at 18:19
  • Most systems are now UEFI, but you are showing BIOS type boot stanzas? So are all installs UEFI on gpt partitioned drives or all BIOS/MBR? Best to keep each drive totally separate, both Windows & Ubuntu want to install boot loaders to first drive in UEFI/BIOS. And Windows wants to have only one Windows boot & uses BCD to list both. Grub then only finds one Windows to boot. help.ubuntu.com/community/Boot-Repair Use ppa in your Ubuntu or live installer & post link to summary report. With multiple drives only use Advanced mode to make any repairs, not any auto fix.
    – oldfred
    Dec 8, 2021 at 19:40

1 Answer 1

0

Had the same problem with Arch linux about a week ago I think, fixed like this:

  1. I made sure os-prober is installed (probably yes)
  2. Installed ntfs-3g IMPORTANT
  3. sudo update-grub

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .