0

I keep finding sources talking about changing the DM and DE using /etc/sysconfig/desktop but when I write this in the file, nothing changes:

DESKTOP="GNOME"
DISPLAYMANAGER="SDDM"

I have already installed sddm.

3
  • @rickhg12hs It does indeed, thanks. The various distros and versions of the same seem to have quite a few ways that you have to learn to do this and I never found this simple method before. Any pointers?
    – okbobby
    Dec 7, 2021 at 1:30
  • I search lots of resources for info: man pages, man -k, Google search (limiting time to last month/year), Stack Exchange sites (usually show up in Google searches), Fedora docs, etc. You should also know that docs/recommendations for other distros, or even older versions of Fedora, may not be appropriate/effective for your version of Fedora. Make sure you backup anything/everything that may be affected by changes you make ... and have a plan to recover to where you started.
    – rickhg12hs
    Dec 7, 2021 at 9:58

1 Answer 1

5

You can use systemctl to switch to SDDM - first disable your current display manager. Do the switch like this:

systemctl disable gdm
systemctl enable sddm

Probably easiest to reboot after this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .