1

I tried installing VirtualBox 6.1 under Debian 11 Bullseye. I followed the tutorial from this answer to Sign virtual box modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) Centos 8. However, I can not allow to disable secure boot and so I follow the second method.

First I create private keys and reboot after importing them with mokutil. I set my password, reboot, follow steps and do as requested. This worked OK.

Then I try signing kernels modules. This is where problems began: modinfo -n vboxdrv, vboxnetflt, vboxnetadp are not found. I go and look for kernels modules using the find command, and I find them (vboxdrv.ko, vboxnetflt.ko, vboxnetadp.ko). So I signed them, and restarted them with systemctl.

Then, second problem. When I start /sbin/vboxconfig, it tells me to sign the vboxdrv, vboxnetflt and vboxnetadp modules. But I just signed them !

I go and execute modinfo -n vboxdrv, vboxnetflt, vboxnetadp again, and here they are found but under a different directory. I tell myself this could be a bug, so I reboot, and after rebooting I'm welcomed with an error message saying something around :

Failed to load options : Invalid Parameter
set_second_stage() failed : Invalid Parameter
Something has gone seriously wrong : shlm_init() failed : Invalid Parameter

I panicked and went into BIOS, checked my boot parameters but did not change a parameter and as nothing changed I reboot. And it worked fine this time. So I go and check modinfo -n vboxdrv, vboxnetflt, vboxnetadp again, and here they are not found.

As you guessed, this now loops. When I boot up, if I don't open BIOS, the error will be outputted again and my laptop won't start.

Also, if this can help, here is the result of dmesg | grep VirtualBox:

[    1.170571] integrity: Loaded X.509 cert 'VirtualBox: 'b9e568a3ad346<something_else>'

The mokutil --list-import command returns my created key as the second key, so I would say it is correctly loaded and imported.

Please help me as I could not find any other topics related to this error, I did not change any boot parameters but I get this nasty error on bootup now!

If required I can edit my question to provide more information.

1 Answer 1

0

Using the following mokutil commands, I could fix my problem.

(in any directory, if you deleted your .der key file)
mokutil -l (check which key you want to delete)
mokutil --export (dumps the keys in numbered files, do NOT delete the wrong key)
mokutil --delete key_name_here (password prompt, note it somewhere)
reboot

On reboot, you'll be granted my an error similar to the second_stage() one, but simply boot into BIOS, don't change anything and simply reboot. You will be prompted with the mokutil menu.

However VirtualBox still is not signed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .