4

I pressed Fn+F5 on my Samsung 9 laptop, which disables the touchpad. It worked, but now I can't re-enable it. Clicking (and even click-through tapping) work, but the pointer doesn't move. If I cat /dev/input/mice, it shows output when I use the touchpad. Restarting the laptop doesn't help, and the touchpad is listed as enabled in the various graphical utilities I tried, including xinput. What else can I try? I'm using Ubuntu 12.10 if it matters.

0
2

I tried swapping my external mouse (/dev/input/mouse0) and my touchpad (/dev/input/mouse1) by renaming their /dev entries, and then rebooting fixed it somehow. I was thinking that renaming devices forced linux to "rescan" (recreate) the /dev files, but then I thought that the /dev filesystem is mounted every reboot and recreated by the kernel, so I don't really understand why that worked.

1
  • fwiw, nothing actually listens to the /dev/input/mouse* event nodes. everything uses /dev/input/event* now – whot Jan 18 '17 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.