1

I'm trying to do a clean install of Ubuntu over pop-os, and whenever I try and boot from USB - and only when I try to boot from USB, I can boot up normally just fine - I get the following screen:

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completion. Anywhere else TAB lists possible device or file completion.

grub>_ 

I have absolutely no clue as to what caused this. I'm a newbie to Linux and haven't messed around with the partitions or anything (knowingly at least). I followed the instructions here:

The other day when I installed Elementary OS in dual boot with Windows, I encountered a Grub error at the reboot time. I was presented with command line with error message:

Minimal BASH like line editing is supported. For the first word, TAB lists possible command completions. anywhere else TAB lists possible device or file completions.

Minimal BASH like line editing is supported Indeed this is not an error specific to Elementary OS. It is a common Grub error that could occur with any Linux OS be it Ubuntu, Fedora, Linux Mint etc.

In this post we shall see how to fix this “minimal BASH like line editing is supported” Grub error in Ubuntu based Linux systems.

You can read this tutorial to fix similar and more frequent issue, error: no such partition grub rescue in Linux

Prerequisites To fix this issue, you would need the followings:

A live USB or disk of (preferably) the same Linux distribution A working internet connection in the live session Once you make sure that you have the prerequisites, let’s see how to fix the black screen of death for Linux (if I can call it that ;)).

Fixing “minimal BASH like line editing is supported” Grub error The process is simple if you follow the steps carefully (not blindly). You may have to change the partition names as per your system.

Step 1: Boot in to the live Linux USB.

Step 2: You need to find out iif your system uses EFI or BIOS. To do that, open the terminal and use the following command to list your partitions:

sudo fdisk -l

Look closely in its output because it could be a huge output. If you see something like EFI, it’s an indication that your system has EFI. This information is important in later stages.

Device        Start       End   Sectors   Size Type /dev/sda1     
2048    976895    974848   476M EFI System /dev/sda2    976896 
40038399  39061504  18.6G Linux filesystem /dev/sda3  40038400 
79099903  39061504  18.6G Linux filesystem /dev/sda4  79099904
468875263 389775360 185.9G Linux filesystem

You need to note two things here. The partition where EFI is installed (if it is installed) and the partition where root partition is installed.

Step 3 (for UEFI systems only): Now, what you need to do is to reinstall grub.

Mount the root partition first. I am using /dev/sda2 for root but you should change this with what you have on your system:

sudo mount /dev/sda2 /mnt 

If you have EFI system, mount that partition as well:

sudo mount /dev/sda1 /mnt/boot/efi

Now, the next step is to finally install grub for UEFI system like this:

sudo grub-install --boot-directory=/mnt/boot --bootloader-id=ubuntu 
--target=x86_64-efi --efi-directory=/mnt/boot/efi

Restart Ubuntu Linux using this command:

shutdown -r now 

You should have the grub back to normal.

My attempt at following this:

binyamin@pop-os:~$ sudo fdisk -l 
[sudo] password for binyamin:  
Disk /dev/nvme0n1: 476.94 GiB, 512110190592 bytes, 1000215216 sectors 
Disk model: SAMSUNG MZALQ512HBLU-00BL2 
Units: sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 16384 bytes / 131072 bytes 
Disklabel type: gpt 
Disk identifier: FD854D1E-4AEC-49E6-8A99-BF137A834EA9

Device             Start        End   Sectors   Size Type
/dev/nvme0n1p1      4096    1023998   1019903   498M EFI System
/dev/nvme0n1p2   1024000    9412606   8388607     4G Microsoft basic data
/dev/nvme0n1p3   9412608  991822510 982409903 468.4G Linux filesystem 
/dev/nvme0n1p4 991822512 1000211118   8388607     4G Linux swap

Partition 4 does not start on physical sector boundary.


Disk /dev/sda: 14.59 GiB, 15669919744 bytes, 30605312 sectors 
Disk model: Cruzer Blade   
Units: sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical): 512 bytes / 512 bytes 
I/O size (minimum/optimal): 512 bytes / 512 bytes 
Disklabel type: dos 
Disk identifier: 0x2cf4ba3a

Device     Boot   Start     End Sectors  Size Id Type 
/dev/sda1  *          0 5999871 5999872  2.9G  0 Empty 
/dev/sda2       5271500 5279499    8000  3.9M ef EFI (FAT-12/16/32)


Disk /dev/mapper/cryptswap: 4 GiB, 4294442496 bytes, 8387583 sectors
Units: sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical):
512 bytes / 512 bytes 
I/O size (minimum/optimal): 16384 bytes / 131072 bytes 
Alignment offset: 8192 bytes 
binyamin@pop-os:~$ sudo mount /dev/nvme0n1p3 /mnt 
binyamin@pop-os:~$ sudo mount /dev/nvme0n1p1 /mnt/boot/efi
binyamin@pop-os:~$ sudo grub-install
--boot-directory=/mnt/boot --bootloader-id=ubuntu 
--target=x86_64-efi --efi-directory=/mnt/boot/efi 
Installing for x86_64-efi platform. Installation finished. No error reported.
--target=x86_64-efi: command not found

I then followed the second method offered on the page for using Boot Repair, but that didn't fix the issue, even though I got a message saying the issue had been resolved - I'd post a link to the pastebin but the URL I got goes to a blank one (https://paste2.org). Every single solution I've seen to this involves booting from a USB, but this is exactly what I'm not able to do. My machine is a Lenovo Ideapad 5, if that's relevant. Any help is greatly appreciated.

2
  • Step back a little. Why do you want to boot from usb? What's on the usb? What's the process you're trying to follow? Please edit your question to provide some context - make sure all the information is in one place and easy to read and follow Dec 1, 2021 at 23:52
  • 1
    Thanks for the feedback. As of now, the USB has an ISO of Ubuntu 20.04 made with Balena Etcher (I wanted to make sure the previous ISO wasn't an issue). As to why I want to boot from USB - well, it's a bit foolish, but I just got a new PC and after struggling and failing to delete a second copy of an application I installed twice (which was pretty much the only thing on it at that point after I had installed pop-os), I figured it would be easier to just do a clean install. That was when I encountered the grub prompt.
    – Benny
    Dec 2, 2021 at 1:21

1 Answer 1

0

I've stumbled upon the exact same problem, tried the exact same solutions you mention and arrived at the same frustrating results. What actually worked was, when booting, choose "Safe Graphics". Worked perfectly for me. Good luck!

Safe graphics options

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Feb 3, 2022 at 12:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .