0

No experience with Freebsd, but I need to write and run a script. Can't install python-ldap or another lib.

An error:

/usr/local/bin/python3.7 -m pip install python-ldap ld-elf.so.1: /lib/libc.so.7: version FBSD_1.6 required by /usr/local/lib/libpython3.7m.so.1.0 not found

This library is in the /usr/local/lib/ folder,

# ls /usr/local/lib/ | grep py
libpython2.7.so
libpython2.7.so.1
libpython2.7.so.1-gdb.py
libpython3.7m.so
libpython3.7m.so.1.0

But if use ldconfig -r

# ldconfig -r | grep py
        91:-lpython2.7.1 => /usr/local/lib/libpython2.7.so.1

I dont know how "rescan" ldconfig. I need your help.

1
  • Please edit in the specific version of FreeBSD 12 you're using. Also, please include the output of file /usr/local/bin/python3.7.
    – Jim L.
    Nov 30, 2021 at 19:42

1 Answer 1

0

FBSD_1.6 refers to FreeBSD 13. What version are you running? Did you install packages for 13 on a FreeBSD 12 installation? Sounds like upgrading FreeBSD will solve the issue.

FreeBSD Symbol versioning

You can see the current version running like this

freebsd-version
uname -mrs
2
  • Hello. Maybe you know how to install old packages for fbsd_1.5? Dec 1, 2021 at 6:12
  • hello, my answer is related to the issue and this is how it will be solved.
    – Alex
    Dec 2, 2021 at 10:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .