I'm running debian buster, and let exim4 deliver for localhost mail from apt-listchanges. this works but I get the error

alex@Taomon:~$ LANG=C
alex@Taomon:~$ systemctl status exim4
* exim4.service - LSB: exim Mail Transport Agent
   Loaded: loaded (/etc/init.d/exim4; generated)
   Active: active (running) since Mon 2021-11-29 10:51:40 CET; 5h 36min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1299 ExecStart=/etc/init.d/exim4 start (code=exited, status=0/SUCCESS)
    Tasks: 1 (limit: 4340)
   Memory: 5.7M
   CGroup: /system.slice/exim4.service
           `-1571 /usr/sbin/exim4 -bd -q30m

Nov 29 10:51:40 Taomon systemd[1]: Starting LSB: exim Mail Transport Agent...
Nov 29 10:51:40 Taomon exim4[1299]: Starting MTA:hostname --fqdn did not return a fully qualified name, dc_minimaldns will not
Nov 29 10:51:40 Taomon exim4[1299]: work. Please fix your /etc/hosts setup.
Nov 29 10:51:40 Taomon exim4[1299]:  exim4.
Nov 29 10:51:40 Taomon systemd[1]: Started LSB: exim Mail Transport Agent.

I read over the years some sides but never understood to solve it. I tried more than once

dpkg-reconfigure exim4-config 

some I hope relevant infos

alex@Taomon:~$ cat /etc/hostname 

    root@Taomon:~# hostnamectl status
       Static hostname: Taomon
             Icon name: computer-laptop
               Chassis: laptop
            Machine ID: 84876d350fa0dd8b520fd47e0000000b
               Boot ID: 0144c780c7d747de92e1fbb41b1b506e
      Operating System: Debian GNU/Linux 10 (buster)
                Kernel: Linux 4.19.0-18-amd64
          Architecture: x86-64

Next to long for here Exim in address testing mode

Note exim delivers my mail correct. But the error makes me nervous. Almost forgot

root@Taomon:~# cat /etc/hosts   localhost   Taomon

#PS4 einbinden

#      PS4

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
#fe00::0 ip6-localnet
#ff00::0 ip6-mcastprefix
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters

1 Answer 1


You have to replace the line   Taomon

in /etc/hosts with  taomon.example.com taomon

from manpage

The recommended method of setting the FQDN is to make the hostname be an alias for the fully qualified name using /etc/hosts, DNS, or NIS. For example, if the hostname was "ursula", one might have a line in /etc/hosts which reads

    ursula.example.com ursula
  • sorry, but I get after restarting exim4.service the same error. Or do I have to reboot the system?
    – nobody
    Nov 29, 2021 at 16:40
  • @nobody Reboot should not be necessary but has the advantage that you know whether it works after a reboot. You have to set the short hostname with the hostname command in that case. And some caching services may prevent the new FQDN from being recognized. Nov 29, 2021 at 17:03
  • 1
    not emough coffee today? It have to be the other whay around. On debian buster taomon.example.com taomon No warnings now. and hostname --fqdn taomon.example.com
    – nobody
    Nov 29, 2021 at 17:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .