3

I am using Debian Wheezy with Xfce and Thunar. Thunar (and other similer managers) enables e.g. connecting to SSH server using SFTP address like sftp://mysvr/ and browsing it like a local folder. I normally access my remote box via command line, but occasionally I appreciate this GUI sugar.

However, in default configuration, this has a pretty annoying downside: File systems accessed this way are automatically mounted under folder $HOME/.gvfs, which creates quite a nightmare for tasks that involve traversing through home folder (typically dotfile searching, or analyzing disk space usage issues).

GNOME 2.2 RNs say:

GVFS also offers a FUSE mountpoint in ~/.gvfs/ so that GVFS mounts can be exposed to legacy applications using standard POSIX IO.

So I guess it's possible to turn this off (I assume by legacy they don't mean Nautilus and the likes).

However, I can't seem to find any information on how to do it. Any pointers?

  • 2
    The -x option to du will solve your analyzing disk space usage problem. – jordanm Mar 14 '13 at 19:14
  • This question is probably outdated, now, since exactly these issues were addressed by moving the GVFS mount point to $XDG_RUNTIME_DIR/gvfs, which typically locates it on a path outside of $HOME such as /run/user/$UID/gvfs. That should be in use on all current systems which support Gvfs/Gio. $HOME/.gvfs is a legacy path. – FeRD Dec 7 '17 at 3:10
4

Gvfsd(1) states:

ENVIRONMENT
       GVFS_DISABLE_FUSE
           If this environment variable is set, gvfsd will not start the fuse
           filesystem.

So if you configure your display manager or ~/.profile to set this variable it should work.

On the other hand most unix utilities have switches to disable recursion into other filesystems (mostly -x, for find it's -xdev)

|improve this answer|||||
  • Thanks, I'm almost embarrassed I did not know about this -x switch. – Alois Mahdal Mar 15 '13 at 19:54
  • Also, before I get to test this, wouldn't this disable the whole feature (using FTPS in managers directly)? – Alois Mahdal Mar 15 '13 at 19:55
  • The variable should only disable ~/.gfvs. Access via GIO should still work. Or do you mean -x? Then I didn't understand your comment. – t-8ch Mar 15 '13 at 20:45
  • No, you understood correctly. I see it's exactly what I was looking for. Thank you. – Alois Mahdal Mar 15 '13 at 21:10
  • Finally made it work, thanks. Just one more question: Where did you get the manual? It's not on my box, and I can't even find any official documentation... – Alois Mahdal Mar 17 '13 at 1:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.