0

I have tried (what a fool!) to install a newer version of glibc on Debian Stretch using dpkg and armhf .pkg files. After a candid

sudo dpkg -i libc6_2.28-10_armhf.deb
sudo dpkg -i libssl1.1_1.1.1d-0+deb10u7_armhf.deb

I got a failed installation because of dependencies not met, and this must have lead to an inconsistent state of my system.

The two problems I have right now:

  1. In python, if I import ssl I get:
    • ImportError: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.25' not found (required by /usr/lib/arm-linux-gnueabihf/libcrypto.so.1.1)
  2. Also apt-get install is not working any more. For example sudo apt-get install gawk complains
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libssl-dev : Depends: libssl1.1 (= 1.1.0l-1~deb9u4) but 1.1.1d-0+deb10u7 is to be installed
 libssl1.1 : Depends: libc6 (>= 2.28) but 2.24-11+deb9u4 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I have tried sudo apt --fix-broken install but no luck, still stuck in unmet dependencies and breaks.

The following packages have unmet dependencies:
 libssl-dev : Depends: libssl1.1 (= 1.1.0l-1~deb9u4) but 1.1.1d-0+deb10u7 is installed
 libssl1.1 : Depends: libc6 (>= 2.28) but 2.24-11+deb9u4 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

This mention of held packages made me try sudo dpkg --remove --pending but this did not give any output nor did change anything of the above tangle of vetoes.

1
  • Thanks @Stephen Kitt! I did not know one could ask for release specific install that way! Do you have good recommendation on how to upgrade to Debian 10 entirely without ending with a bricked pi? My experience so far is that just doing sudo apt update sudo apt dist-upgrade -y does not work. And I hate to discover if my backup works or not : )
    – Rho Phi
    Nov 29, 2021 at 8:32

1 Answer 1

0

To fix this, you can downgrade:

sudo apt install libc6/stretch libssl1.1/stretch

Alternatively you could figure out what the missing dependencies are, but you might as well upgrade to Debian 10 entirely if you want to go down that route.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .