1

I've had some issues with Bluetooth for a few months now and when I finally got around to troubleshooting it I got stuck:

The Problem: When I turn off Bluetooth in the gnome-control-center, the UI gets unresponsive and the only way to re-enable it I found is rebooting.

What I've tried:

  • connect devices through blueman: got the error "Connection Failed: Resource not Ready"

  • typing systemctl restart bluetooth. Still not able to connect to devices through gnome-control-center or blueman

  • following a comment from Github I tried

bluetoothctl
power on
discoverable on
pairable on
scan on

All the commands seemed to work flawlessly except the scan on which threw "org.bluez.Error.NotReady", but when running bluetoothctl show, I get:

    Name: pop-os
    Alias: pop-os
    Class: 0x00000000
    Powered: no
    Discoverable: yes
    DiscoverableTimeout: 0x00000000
    Pairable: yes
    UUID: Message Notification Se.. (00001133-0000-1000-8000-00805f9b34fb)
    UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
    UUID: OBEX Object Push          (00001105-0000-1000-8000-00805f9b34fb)
    UUID: Message Access Server     (00001132-0000-1000-8000-00805f9b34fb)
    UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
    UUID: IrMC Sync                 (00001104-0000-1000-8000-00805f9b34fb)
    UUID: Vendor specific           (00005005-0000-1000-8000-0002ee000001)
    UUID: Headset AG                (00001112-0000-1000-8000-00805f9b34fb)
    UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
    UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
    UUID: Phonebook Access Server   (0000112f-0000-1000-8000-00805f9b34fb)
    UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
    UUID: Device Information        (0000180a-0000-1000-8000-00805f9b34fb)
    UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
    UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
    UUID: Audio Source              (0000110a-0000-1000-8000-00805f9b34fb)
    UUID: OBEX File Transfer        (00001106-0000-1000-8000-00805f9b34fb)
    Modalias: usb:v1D6Bp0246d0538
    Discovering: no
    Roles: central
    Roles: peripheral

I am not sure why I have "powered: no" above. I guess that means bluetoothctl power on did not work after all, even though I got "Changing power on succeeded" back?

Any hints on what I should try next would be very appreciated.

OS: Pop-OS (Ubuntu 21.04) with regolith on top.

1 Answer 1

3

Found a fix here https://askubuntu.com/a/1167726/1197984: Running the following in the shell solved my issue:

sudo rmmod btusb
sudo modprobe btusb

(Sorry seems like I don't have enough reputation yet to accept my own answer?)

1
  • You have to wait 48 hours before you can accept it. Commented Nov 27, 2021 at 22:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .