0

I'm new to arch linux

I haven't installed Arch yet, but that's my problem.

When I run ping 1.1.1.1 or ping 8.8.8.8, I get an error...

The following error appears:

ping: connect: Network is unreachable

My connection type is by ethernet I made a bootable usb wit the ArchISO and i followed the the procedures of Arch Linux Installation Guide! When i reached "Connecting the internet" i made the ping comnmand! But didn't work (the error is above) Here what i tried: ip link set enp30s0 up

I tried the ip link command to see what my ethernet controller is called. It's called enp30s0.

So I tried dhcpcd enp30s0 but I got a weird error:

Failed to set DNS configuration: Failed to activate service 'org.freedesktop.network1': timed out (service_start_timeout=25000ms)

Failed to revert interface configuration: Failed to activate service 'org.freedesktop.network1': timed out (service_start_timeout=25000ms)
time out

I didn't try that much (true) but as i said, i'm new!!! I don't know what's going on

I am not using a virtual machine

I have the following components:

two discs: sda 237 GB (which has Windows 10 installed)

sdb 465 GB (which is where I want to install Arch Linux)

If you could help me I would appreciate it!

PS: I'm totally new to arch linux so I hope the problem is easy to solve :(

7
  • Welcome on U&L! "I haven't installed Arch yet": did you boot off an Arch ISO image? Are you following the Installation guide? It will likely be easier to help you if we can understand what procedure you are following, what did you do and where you are stuck at.
    – fra-san
    Nov 26, 2021 at 19:07
  • i just edited my question
    – Devilas
    Nov 26, 2021 at 19:14
  • i added what is tried. But i didn't tried to much, because like i said, im new!
    – Devilas
    Nov 26, 2021 at 19:15
  • Thank you! I'd suggest you to add your system's hardware model and network card model to your question. Then, to understand what's going on, you can try: lspci -v, looking for a block relating to your ethernet card and particularly the "Kernel driver in use" and "Kernel modules" lines; journalctl -b 0 -u systemd-networkd -u systemd-resolved to inspect the logs about the networking-related services, looking for errors; ip addr to see how your network interface is configured. You may add these commands' output to your question if you feel it's relevant or if you are not sure.
    – fra-san
    Nov 26, 2021 at 20:15
  • (continued) Finally, to make sure about the basic stuff: is there a DHCP server on the network your card is connected to (and are you sure it is working)?
    – fra-san
    Nov 26, 2021 at 20:16

1 Answer 1

0

I resolved the problem!

In my computer I have a USB internet card too... When I started the USB bootable medium a message appeared saying:

rtl_usb: reg 0x80, usbctrl_vendorreq Time out! status: 0xffffff92 value=0xa500

Then I read the error with more attention and I disconnected the USB internet card, and it worked!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.