0

When I trying to boot Linux (Debian 10) through rEFInd it boots in initramfs shell. It cannot find the root. But when I edit cmdline boot option by F2 and setting root manually (root=dev/sda5) it boots just fine.

The source of problem was Windows. After I connected old malfunctioning HDD through SATA to PC, copied files from it and tried to shutdown PC Windows 8.1 displayed some error related to NTFS failure. And it rebooted and started "repairing" and overwritten rEFInd.

I booted from Debian livecd to chroot installed system and reinstalled rEFInd.

I tried update-initramfs, but it didn't work

1 Answer 1

2

Find the rEFInd configuration file(s):

find /boot/efi -name 'refind*.conf'

You might find one or two files: refind.conf and possibly also refind_linux.conf. If the latter exists, the default boot options will most likely be there; if not, then the full configuration will be in the main refind.conf file.

Edit the appropriate file using your favorite text editor.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .