0

I have an Aftershock Vapor 15X (Eluktronics Max 15) with i7-10870H and RTX3060. Even I though I set the refresh rate = 165Hz in the settings, it still renders at 40Hz. Ive tried using multiple DEs like gnome, xfce and kde and the same thing happens each time. Xrandr says its rendering at 1440p 165Hz as well.

  • I've tried multiple linux distros, ubuntu, manjaro and debian, same problem. I also installed FreeBSD and installed KDE, same issue - perhaps something wrong with bios or DE?

  • I've tried uninstalling intel graphics drivers but it did nothing.

  • I've tried setting nvidia prime offset 1, no effect.

  • I set the bios to only use dGPU, which worked, but had problems loading the display manager on boot. The screen flickers for a while before loading in.

I think it has something to do with nvidia optimus or some compatibility issues due to newer hardware. Or perhaps something with the intel drivers. Any ideas?

2
  • How are you checking the actual refresh rate? (i.e. how do you know it's 40 Hz)
    – Enrico
    Nov 25 at 14:40
  • The UFO test says its 40fps
    – Capital11
    Nov 25 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.