3

Currently I am using a Debian 11 system. Something seems to be completely off with music players. I first tried cmus to no avail (cmus would give errors on startup and not show any mp3 files) I then tried mocp. Using mocp I can see the files but upon trying to play said files it will say "playing" for a fraction of a second and stop with no errors. I can play said files with ffplay just fine, but the original goal was to have a decent looking terminal-based mp3 player to play my songs.

I have tried using mocp -D and I will give the logs that stand out here:

Nov 24 23:47:18.447269: interface.c:674 ev_file_tags(): Received tags for /home/me/music/song.mp3
Nov 24 23:47:18.447918: interface.c:692 ev_file_tags(): Tags apply to the currently played file.
Nov 24 23:47:18.448008: interface.c:3482 dequeue_events(): done
Nov 24 23:47:18.460880: interface.c:1115 server_event(): EVENT: 0x0f

but this doesn't really tell me anything. If it's of use, I have installed cmus both via building from github and from the Debian repository and mocp from the Debian repository.

2
  • I use mpg123, it works great. Commented Nov 29, 2021 at 4:50
  • What were the errors that cmus gave? Where they related to the mocp errors? Please edit and update your question with the errors - they may be of use. Commented Nov 29, 2021 at 12:08

1 Answer 1

0

A very, very, very long time ago (Debian 5 IIRC), I used mp3blaster and I was very happy with it.

It seems it is still available at Debian 11, so give it a try (I am not sure if it will work with pulseaudio if you use it)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .