0

Hello i am trying to copy the file from my ubuntu machine to windows machine using scp without entering the password. I have set up the openssh key and followed the steps to enable the password less file trasfer setting by setting authorized keys. But still the scp command asks for password.

Facing issue to resolve the same. Request you to please help me on same.

5
  • Are you pushing the file from Ubuntu to Windows or are you pulling the file? Did you check the private key's permission? Have you tried increasing the debug output of the client and the server?
    – Hermann
    Commented Nov 24, 2021 at 9:33
  • i am pushing from ubuntu to windows i copied public key from linux to windows as authorized_keys still issye is there.
    – santosh
    Commented Nov 24, 2021 at 9:36
  • 1
    This seems more a Windows issue than a Linux/Unix issue. See woshub.com/using-ssh-key-based-authentication-on-windows Commented Nov 24, 2021 at 10:11
  • @Ljm Dullart Thank you for the response but i tried th same still issue persist.
    – santosh
    Commented Nov 24, 2021 at 11:21
  • OK then; do ssh -v your.windows.machine on Ubuntu and add the output to your question. Commented Nov 24, 2021 at 12:26

1 Answer 1

0

I was able to solve the issue by commenting admin_authorized_keys as it was looking for this file for authorized keys despite of authorized_keys.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .