4

I have recently installed CentOS Stream 9 and I'm finding that I can't get epel to work properly following any instructions I can find online. Resources for CentOS 8 / CentOS Stream 8 don't work and there are barely any resources for CentOS 9 Stream.

I want to install epel so I can install packages like ddclient, but I can't figure it out. Normally I'd just do this:

dnf install epel-release
dnf config-manager --set-enabled powertools  # I have also tried PowerTools

But I get this error:

Error: No matching repo to modify: powertools.

I have messed around a lot trying to get epel so my set up may be messed up now, but here are my currently installed relevant packages and repos:

$ dnf list installed | grep -E 'centos|epel'
centos-gpg-keys.noarch                        9.0-3.el9                      @baseos
centos-logos.x86_64                           90.4-1.el9                     @AppStream
centos-logos-httpd.noarch                     90.4-1.el9                     @appstream
centos-stream-release.noarch                  9.0-3.el9                      @baseos
centos-stream-repos.noarch                    9.0-3.el9                      @baseos
epel-release.noarch                           8-13.el8                       @@commandline

$ dnf repolist
repo id                                                              repo name
Plex                                                                 Plex
appstream                                                            CentOS Stream 9 - AppStream
baseos                                                               CentOS Stream 9 - BaseOS

Any help would be much appreciated, I'm almost at the point of just wiping and installing CentOS Stream 8 instead.

Thanks!

2 Answers 2

5

powertools are called crb(CodeReady Linux Builder) now. To enable it, run

dnf config-manager --set-enabled crb
  1. https://developers.redhat.com/blog/2018/11/15/introducing-codeready-linux-builder
0

I don't think it's possible yet. I tried it too, but failed. I installed epel-release and epel-next-release from official Fedora project, but I was not able to install further packages from EPEL.

It seems there isn't any yet. I tried to search in multiple sites, but didn't find any solutions. Not even on the CentOS mirror, where the 9-stream folder is missing entirely.

For me the only solution was to downgrade to CentOS Stream 8.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.