0

First and foremost, I'm trying to purge an improperly uninstalled version of Intellij-Idea on Raspberry Pi and reinstall.

I installed IntelliJ-Idea on the Raspberry Pi using the below page as a guide:

Install Intellij-Idea on Raspberry Pi

After progressive success decreasing CPU/memory usage, and countless lock-up and kill the jvm loops, I ran into a wall with continuing "OutOfMemory" exceptions after the application launched fine and ran for a few minutes. (It indexes nearly the entire JVM, maven, my home folder, etc.)

Yes, I increased JVM memory allocation (-Xms/-Xmx), increased swap space, etc. Thinking the root of my problem might be a caching issue, I tried to remove a few folders I thought were cache directories, but actually wiped out the main install image and all subdirectories instead.

So now I'm trying to force uninstall/delete so I can re-install. I've tried:

  1. Uninstalling from Add/Remove Software (Only supporting packages list as "installed". The main install doesn't list at all)
  2. sudo apt-get purge/remove intelliJ* (see below output)
  3. sudo apt purge/remove intelliJ* (ditto)
  4. Got frustrated and manually deleted all the other "IdeaIC2021.2" and related folders (after backing up key config files) The start menu link won't work now of course, but I can't get pi to truly purge details and let me reinstall.

Bizarre half-installed state messages:

pi@raspberrypi:~ $ sudo apt purge intelliJ*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libjdom2-intellij-java-doc' for regex 'intelliJ*'
Note, selecting 'libintellij-annotations-java-doc' for regex 'intelliJ*'
Note, selecting 'libjdom2-intellij-java' for regex 'intelliJ*'
Note, selecting 'libintellij-annotations-java' for regex 'intelliJ*'
Package 'libintellij-annotations-java' is not installed, so not removed
Package 'libintellij-annotations-java-doc' is not installed, so not removed
Package 'libjdom2-intellij-java' is not installed, so not removed
Package 'libjdom2-intellij-java-doc' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Yes, I'm an idiot for deleting the wrong folder and then digging the hole deeper, but at this point I just want to overlay with a new install anyway. What's the correct way forward? Manual download and install because pi's registration details are horked? A set of sudo apt-get install commands?

1 Answer 1

0

I manually downloaded a new installation since the Add/Remove software option wasn't letting me go further. It wasn't perfect, but it was better than a dead-end. In my search, I stumbled across this:

JetBrains ends 32-bit OS support

JetBrains only supported 32bit up to 2021.1.x, and the current version is 2021.3.x. I downloaded a down-level version here:

Install other/mostly older versions of Idea

Otherwise I need to wait until Raspbian officially supports 64-bit:

Raspberry Pi 64 bit status

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .