0

What should I do, I have set up everything for what I thought would be a wonderful well running zabbix server and now it is not running on the final step. I cannot figure out what went wrong. How can I fix this? this is my first time, please help thanks :)enter image description here

?php
// Zabbix GUI configuration file.

$DB['TYPE']                             = 'MYSQL';
$DB['SERVER']                   = 'localhost';
$DB['PORT']                             = '0';
$DB['DATABASE']                 = 'zabbix';
$DB['USER']                             = 'zabbix';
$DB['PASSWORD']                 = 'zabbix_db_pass';

// Schema name. Used for PostgreSQL.
$DB['SCHEMA']                   = '';

// Used for TLS connection.
$DB['ENCRYPTION']               = false;
$DB['KEY_FILE']                 = '';
$DB['CERT_FILE']                = '';
$DB['CA_FILE']                  = '';
$DB['VERIFY_HOST']              = false;
$DB['CIPHER_LIST']              = '';

// Use IEEE754 compatible value range for 64-bit Numeric (float) history values.
"/etc/zabbix/web/zabbix.conf.php" 47L, 1484C

///////zabix.conf.php starts here

// Use IEEE754 compatible value range for 64-bit Numeric (float) history values.
// This option is enabled by default for new Zabbix installations.
// For upgraded installations, please read database upgrade notes before enabling this$
$DB['DOUBLE_IEEE754']   = true;

$ZBX_SERVER                             = 'localhost';
$ZBX_SERVER_PORT                = '10051';
$ZBX_SERVER_NAME                = '';

$IMAGE_FORMAT_DEFAULT   = IMAGE_FORMAT_PNG;

// Uncomment this block only if you are using Elasticsearch.
// Elasticsearch url (can be string if same url is used for all types).
//$HISTORY['url'] = [
// 'uint' => 'http://localhost:9200',
// 'text' => 'http://localhost:9200'
//];

I also noticed this little message in firewall status:

firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2021-11-22 13:14:25 EST; 2h 5min ago
     Docs: man:firewalld(1)
 Main PID: 767 (firewalld)
    Tasks: 2
   CGroup: /system.slice/firewalld.service

it seems like there is just so much going on in my server and I do not know where to edit it. Can anyone give me some help on finding a guide compatible with CentOS Linux release 7.9,2009 (core)

8
  • maybe you have to start the server
    – jsotola
    Nov 22 at 20:51
  • I am pretty sure the server is enabled. but if u want to send me some commands. that would be great.
    – Amanda W
    Nov 22 at 21:04
  • 1
    google zabbix server start stop
    – jsotola
    Nov 22 at 21:24
  • You checked the status of the firewall, but not the status of zabbix-server? Do that first. If it's not running, start it. If it still doesn't work, check logfiles for errors.
    – Panki
    Nov 22 at 22:42
  • I restarted it and started it again then checked status. The server is still not running. I just do not get it. If someone can give me a guide that is compatible with my version of CentOS 7 then that would be great.
    – Amanda W
    Nov 23 at 4:22
0

If you've gotten to the end the Download and install Zabbix instructions and the services aren't running, it seems worth it to try the "Start Zabbix server and agent processes" commands:

systemctl restart zabbix-server zabbix-agent httpd php-fpm
systemctl enable zabbix-server zabbix-agent httpd php-fpm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.