0

Yesterday I installed updates, wanted to copy something with Ctrl+Shift+C and accidentally terminated a kernel update with Ctrl+C. I then started the update process again, but since the following reboot, the system fails to start and I get this error message from Grub:

error: file `/boot/vmlinuz-5.10-x86_64' not found.
error: you need to load the kernel first.
Press any key to continue...
Failed to load both default and fallback entries.
Press any key to continue...

Then I get thrown into the Grub menu. The "Advanced options for Manjaro Linux" menu contains the entries "Manjaro Linux (Kernel: 5.10.70-1-MANJARO x64)" and "Manjaro Linux (Kernel: 5.10.70-1-MANJARO x64 - fallback initramfs)". Both just lead back to the same error.

If I run ls (hd1,gpt2)/boot (system partition) in the Grub command line, the only relevant entry is:

linux510-x86_64.kver

With ls (hd1,gpt1)/boot (boot partition), the output looks much better, the relevant entries are:

linux510-x86_64.kver
vmlinuz-5.10-x86_64
initramfs-5.10-x86_64.img
initramfs-5.10-x86_64-fallback.img
linux515-x86_64.kver
vmlinuz-5.15-x86_64
initramfs-5.15-x86_64.img
initramfs-5.15-x86_64-fallback.img

The 5.15 kernel is one that I installed using a live boot USB and chroot, so something must have worked there… But it's still not booting.

I don't know all the attempts that I made anymore, mainly because every reboot today has reset my browser history, but some of them are:

  • reinstalling all linux510* packages
  • installing another kernel version with mhwd-kernel
  • running various combinations of grub-mkconfig, mkinitcpio, grub-install and update-grub inside manjaro-chroot (In the last few rounds their outputs all looked successful.)

I have not tried rolling back the updates, because last time I tried that, it just made the mess bigger.

I'm using the regular (non-beta) version of Manjaro and have not messed around much with Grub before. I'm not even using any dual-boot setups, unlike apparently most people with similar problems. I could list some of the package updates, if that helps, but for now I won't, because there are >1400 of them. Some version numbers of installed packages:

  • manjaro-release 21.2pre-1
  • grub 2.06-1
  • linux510 5.10.79-1

The live USB is also Manjaro, but an older version, with only the necessary updates installed.

Why does Grub not find the file that is apparently there? And of course: How can I fix this?

1 Answer 1

0

My system is now fixed, but I don't know which of the steps that I took were actually necessary. What was probably the most important part was completely uninstalling the active kernel and reinstalling it then, instead of "just" reinstalling it in place. mhwd-kernel -r linux510 does not work if the 5.10 kernel is currently in use, but this works:

yay -Rdd linux510 linux510-acpi_call linux510-bbswitch linux510-broadcom-wl linux510-headers linux510-nvidia linux510-r8168 linux510-rtl8723bu linux510-tp_smapi linux510-vhba-module linux510-virtualbox-host-modules

The dd part makes it ignore all dependency issues.

I also uninstalled the 5.15 kernel again that I had installed during troubleshooting. Then I reinstalled the 5.10 kernel with something similar to this:

yay -S linux510 linux510-extramodules

After this, the /boot directory contained the files initramfs-5.10-x86_64-fallback.img, initramfs-5.10-x86_64.img, intel-ucode.img and vmlinuz-5.10-x86_64 that weren't there before.


I also used this command:

grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=GRUB

In there, I did not use the EFI directory /boot/EFI, even though it does exist. I don't know if this command was necessary.

I also used these commands:

grub-mkconfig -o /boot/grub/grub.cfg
mkinitcpio -P
update-grub

I don't know which of these, if any, were necessary. Afterwards, I rebooted, selected the entry starting with "UEFI" in Bios and the system started normally again.

1
  • BTW, since then I've added stty intr ^- and stty -ixon into my .bashrc file, rebound all the usual shortcuts to Ctrl+X/C/V/A and the softer and harder process kill signals to Ctrl(+Shift)+Esc. Much nicer! I can still kill stuff easily, but don't do it accidentally all the time. All modern programs should have these normal shortcuts, Ctrl+C to kill is almost as bad as IntelliJ's former Ctrl+Y to change something instead of redoing or Google Sheets' Ctrl+R to delete instead of reloading. Jun 3, 2022 at 18:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .