0

I am having trouble with my screen blanking. I am using a waveshare 1.3 inch lcd screen on a raspberry pi running dietpi 7.8.2. No matter what I try, the screen blanks after 60 seconds with no input. In fact, the backlight turns off as well. I can wake the screen up with some types of input. ctrl+c and enter seem to work. I have tried several things to turn off this behavior, but I cannot seem to get the screen to stay on.

Here are some details on things I have tried and my settings:

cat /sys/module/kernel/parameters/consoleblank
0

Some settings from my /boot/config.txt

hdmi_force_hotplug=1
hdmi_cvt=300 300 60 1 0 0 0
hdmi_group=2
hdmi_mode=87
display_rotate=0
consoleblank=0

I have tried setterm --blank 0 and setterm --powerdown 0 as well.

1 Answer 1

0

I have a dietpi on a normal monitor or over ssh. I can come up with 4 solutions, listed below in order of likelihood to solve the problem:

  1. /sys/class/backlight/acpi_video0/power/ explained at the end (most likley)

  2. dietpi-config (I guess you already did that command.)

  3. The screens ribbon/cable/piggyback or gpio connector to the screen connections are lose and when it warms up or is moved, it blanks out. The engineers trick is to squeeze the joint to see if it comes back intermittently, or re-solder "dry solder" joints or the best trick is if the ribbon is clip-in to use a graphite 2B or softer 0.3mm engineering pencil to draw back each and every ribbon contact; it works like magic.

    Obviously graphite is conductive so do not draw randomly and do not drop bits on boards! Do it when powered off.

  4. Waveshare: some screens have been discontinued and are "pants". However waveshare in general is very good quality.

I found this directory which may help:

cd /sys/class/backlight

Under there are a number of directories and files specifically in my case (that may differ from yours):

$ cd /sys/class/backlight/acpi_video0
dietpi@pihole:/sys/class/backlight/acpi_video0$
-rw-r--r-- 1 root root 4096 May 16 14:33 uevent
lrwxrwxrwx 1 root root    0 May 16 14:33 subsystem -> ../../../../../class/backlight/
-r--r--r-- 1 root root 4096 May 16 14:33 type
-r--r--r-- 1 root root 4096 May 16 14:33 max_brightness
-rw-r--r-- 1 root root 4096 May 16 14:33 brightness
drwxr-xr-x 2 root root    0 May 17 09:50 power/   # <<< THIS DIRECTORY!
-r--r--r-- 1 root root 4096 May 20 20:17 scale
lrwxrwxrwx 1 root root    0 May 20 20:17 device -> ../../../0000:00:01.0/
-rw-r--r-- 1 root root 4096 May 20 20:17 bl_power
-r--r--r-- 1 root root 4096 May 20 20:17 actual_brightness

I found the file in the directory power/ to be of most interest and entries in there to be set mostly to just one line:

0

Zero 0 in timings usually means either OFF or it means run forever without a timeout. I am guessing one of those files has 60 in it!

In addition I found another user using the xset command but the dietpi did not have that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .