1

I'm trying to install KDE on CentOS 8 but I'm not able to. I recently had problems updating packages and run dnf --refresh --best --allowerasing update. This removed KDE an all related apps (yeah, I know that it warned me, but I though I could easily reinstall it later...).

I've found online several turorials (e.g this one), but when I try to follow them I get a "conflicting requests" error (only showing the first 3 errors, but I'm getting the same error for 54 packages):

[user@localhost ~]$ sudo dnf groupinstall "KDE Plasma Workspaces" "base-x" -y
Updating Subscription Management repositories.
Unable to read consumer identity

This system is not registered with an entitlement server. You can use subscription-manager to register.

Last metadata expiration check: 1:48:35 ago on Wed 17 Nov 2021 08:45:49 AM CET.
No match for group package "k3b-extras-freeworld"
Error: 
 Problem 1: conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.12.5_PRIVATE_API)(64bit) needed by kf5-akonadi-server-19.12.2-1.el8.1.x86_64
  - nothing provides libQt5Sql.so.5(Qt_5.12.5_PRIVATE_API)(64bit) needed by kf5-akonadi-server-19.12.2-1.el8.1.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.12.5 needed by kf5-akonadi-server-19.12.2-1.el8.1.x86_64
 Problem 2: package kwebkitpart-1.4.0-0.6.20190110.el8.x86_64 requires libQt5WebKit.so.5()(64bit), but none of the providers can be installed
  - package kwebkitpart-1.4.0-0.6.20190110.el8.x86_64 requires libQt5WebKitWidgets.so.5()(64bit), but none of the providers can be installed
  - package kwebkitpart-1.4.0-0.6.20190110.el8.x86_64 requires libQt5WebKitWidgets.so.5(Qt_5)(64bit), but none of the providers can be installed
  - package kwebkitpart-1.4.0-0.6.20190110.el8.x86_64 requires libQt5WebKit.so.5(Qt_5)(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Gui.so.5(Qt_5.12.5_PRIVATE_API)(64bit) needed by qt5-qtwebkit-5.212.0-0.42.alpha3.el8.x86_64
  - nothing provides libQt5Quick.so.5(Qt_5.12.5_PRIVATE_API)(64bit) needed by qt5-qtwebkit-5.212.0-0.42.alpha3.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.12.5 needed by qt5-qtwebkit-5.212.0-0.42.alpha3.el8.x86_64
  - nothing provides qt5-qtdeclarative(x86-64) = 5.12.5 needed by qt5-qtwebkit-5.212.0-0.42.alpha3.el8.x86_64
 Problem 3: package kdeplasma-addons-5.18.4.1-1.el8.x86_64 requires libQt5WebEngineCore.so.5()(64bit), but none of the providers can be installed
  - package kdeplasma-addons-5.18.4.1-1.el8.x86_64 requires libQt5WebEngineCore.so.5(Qt_5)(64bit), but none of the providers can be installed
  - package kdeplasma-addons-5.18.4.1-1.el8.x86_64 requires libQt5WebEngine.so.5()(64bit), but none of the providers can be installed
  - package kdeplasma-addons-5.18.4.1-1.el8.x86_64 requires libQt5WebEngine.so.5(Qt_5)(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Gui.so.5(Qt_5.12.5_PRIVATE_API)(64bit) needed by qt5-qtwebengine-5.12.8-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.12.5 needed by qt5-qtwebengine-5.12.8-1.el8.x86_64

What should I do to fix it?

In case it is a problem with the repos, here the list:

[user@localhost ~]$ sudo dnf repolist
Updating Subscription Management repositories.
Unable to read consumer identity

This system is not registered with an entitlement server. You can use subscription-manager to register.

repo id                                                           repo name
BellSoft                                                          BellSoft Repository
appstream                                                         CentOS Linux 8 - AppStream
baseos                                                            CentOS Linux 8 - BaseOS
epel                                                              Extra Packages for Enterprise Linux 8 - x86_64
epel-modular                                                      Extra Packages for Enterprise Linux Modular 8 - x86_64
epel-multimedia                                                   negativo17 - Multimedia
extras                                                            CentOS Linux 8 - Extras
google-chrome                                                     google-chrome
owncloud                                                          owncloud
powertools                                                        CentOS Linux 8 - PowerTools
rpmfusion-free-updates                                            RPM Fusion for EL 8 - Free - Updates
rpmfusion-nonfree-updates                                         RPM Fusion for EL 8 - Nonfree - Updates
teams                                                             teams

I'm not sure if I need all - if necessary I'll remove them to get KDE back.

Here also the history:

[user@localhost ~]$ sudo dnf history
Updating Subscription Management repositories.
Unable to read consumer identity

This system is not registered with an entitlement server. You can use subscription-manager to register.

ID     | Command line                                                                                               | Date and time    | Action(s)      | Altered
-----------------------------------------------------------------------------------------------------------------------------------------------------------------
   123 | history undo 122                                                                                           | 2021-11-17 08:54 | Removed        |    3   
   122 | install GConf2-devel                                                                                       | 2021-11-16 23:03 | Install        |    3   
   121 |                                                                                                            | 2021-11-16 23:01 | Install        |    1   
   120 | --enablerepo=epel,powertools group -y install KDE Plasma Workspaces base-x --nobest --skip-broken          | 2021-11-16 22:39 | Install        |    3   
   119 | --refresh --best --allowerasing update                                                                     | 2021-11-16 22:04 | E, I, O, U     |  848 EE
   118 | remove tesseract                                                                                           | 2021-11-16 22:03 | Removed        |   35 EE
   117 | update                                                                                                     | 2021-11-15 17:36 | Upgrade        |   58 EE

The problem happened in 119, but I'm unable to undo it (sudo dnf history undo 119 fails)

4
  • It's about long time kde5 / qt5 issues, and the problems seem to be fixed these days. Fedora 34 and 35 are OK. (PCLinuxOS: Most KDE, qt5 now got updated.) .... So hopefully consistent KDE, qt5 will soon come to EPEL/centos 8 Nov 17, 2021 at 12:21
  • @KnudLarsen Thanks for the comment! I'm not sure if I understand... do you mean that it'll get fixed in the next time and the easiest solution is just to wait a bit until the packages get updated?
    – Robe
    Nov 17, 2021 at 12:46
  • 1
    I updated Rocky 8.4 yesterday, except for the qt5 packages. I will let you know when the 15 qt5 packages (all appstream) can be used . I have a couple of CentOS 8 to check too. List → dnf list --upgradesdrive.google.com/file/d/11dJUH6CVCmdchj2VtT_Tt0dr_GIYWa9-/… . (There were no KDE packages to update now.) Nov 17, 2021 at 15:11
  • @KnudLarsen Great, then I'll wait!
    – Robe
    Nov 17, 2021 at 20:35

1 Answer 1

1

An official update of the qt packages fixed the issue

1
  • Yes, OK now. .... Please note that Redhat stops with CentOS 8 updates Dec 31 - 2021 : You can migrate the OS to e.g. Rocky Linux 8. Dec 1, 2021 at 16:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .