The title might be misleading but I did not found a better and shorter way to put it so here is some context.

When I configure the touch-pad to scroll the natural way, it works. As soon as I reboot, it does not anymore. But when I access the settings, it shows the good setting. I have to unselect+reselect the setting to make it work again.

nixos touch-pad scrolling settings

Any idea what's wrong and how to fix this behaviour?

1 Answer 1


I casually found out that I could add this to my configuration.nix:

  services.xserver.desktopManager.gnome.extraGSettingsOverrides = ''

I just rebooted and it seems to stick. I don't know if there is a more appropriate way?

  • Sounds like the initial behavior is a bug, might be worth reporting. Nov 18, 2021 at 15:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .