0

I have two sets of Linux VMs in a GCP (Google cloud) environment: Debian9 and RHEL8. The RHEL8 environment is FIPS-140 enabled, due to security/compliance requirements. None of our Ansible playbooks work with the FIPS-enabled RHEL VMs, but still work fine on the Debian VMs. The Linux control host is Debian9 as well.

For the failed RHEL8 playbooks , seeing this log in the Ansible playbook -vvvv output:

ValueError: [digital envelope routines: EVP_DigestInit_ex] disabled for FIPS

What are some things I can look at to get these Playbooks working withe RHEL8/FIPS VMs?

1
  • 1
    What are some of the things you have looked for and already tried? A simple google search shows a LOT of hits, many several years old. This does not look like a new problem. And it may or may not be an Ansible problem. More info on what is failing, and what you have already tried, may allow the community here to help you. The tour and user-guide on how to ask a good question will help a lot.
    – 0xSheepdog
    Commented Nov 13, 2021 at 20:10

1 Answer 1

1

This is solved by upgrading the Ansible version. Previous version was 2.7. Upgrading to current (latest) version fixed it.

1
  • For background information why the upgrade solved the issue, one may have a look into New LibSSH Connection Plugin for Ansible ... Adds FIPS Mode Enablement. Quote: "The primary reason to replace ... library is that it doesn’t guarantee FIPS readiness and thus limits the Ansible network capability to run in environments that mandate FIPS mode to be enabled."
    – U880D
    Commented Jan 19, 2022 at 20:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .