I've installed Debian 11 with dual boot on a laptop of mine lately. I installed the official image, so no non-free drivers got installed.

I had some driver issues reported when using dmesg (I think one was the bluetooth) and I seemed to have fixed them by installing some packages (I copied the failing driver name from dmesg, searched it with apt, and installed the best match).

At some point I've decided to add the contrib and non-free sources to my sources list, to see if getting non-free drivers would improve anything: https://www.xmodulo.com/install-nonfree-packages-debian.html

I was getting errors from the nouveau driver before that too (despite the fact that my screen was using the full resolution), so I was just trying to make the errors go away.

I've tried the nvidia-detect utility and after installing its suggestion my resolution dropped and wouldn't be set to a higher one. So, I've uninstalled that.

I've also tried the instructions here: https://wiki.debian.org/NvidiaGraphicsDrivers#Debian_11_.22Bullseye.22 Again, my resolution dropped.

I think that, in both cases I've installed a legacy driver (most likely nvidia-legacy-390xx-driver).

My graphics card seem to be a GA compatible controller: NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1).

Eventually, I have uninstalled what I had installed (hopefully - not sure if anything stayed behind...) and my resolution is now restored, but I still get the same errors in dmesg:

[   14.913827] Bluetooth: Can't change to loading configuration err
[   14.913943] ath3k: probe of 1-1.5:1.0 failed with error -110
[   37.345865] nouveau 0000:01:00.0: firmware: failed to load nouveau/nvc1_fuc084 (-2)
[   37.345872] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[   37.345876] nouveau 0000:01:00.0: Direct firmware load for nouveau/nvc1_fuc084 failed with error -2
[   37.345892] nouveau 0000:01:00.0: firmware: failed to load nouveau/nvc1_fuc084d (-2)
[   37.345895] nouveau 0000:01:00.0: Direct firmware load for nouveau/nvc1_fuc084d failed with error -2
[   37.345898] nouveau 0000:01:00.0: msvld: unable to load firmware data
[   37.345901] nouveau 0000:01:00.0: msvld: init failed, -19

These seem to be the only remaining errors.

If we exclude the bluetooth one at the top (which I have no idea why it happens), you see the failing nouveau driver afterwards.

And I am a bit confused by it really, because (from my understanding) the nouveau driver is supposed to be shipped with the kernel. So, why would it fail? How could there be a missing dependency to it or anything like that?

I think I also tried installing it (nouveau) with apt, but nothing got installed. Not sure what would happen if one of its dependencies was the wrong version (if it would be replaced or not). I guess it would be replaced if the existing binary is an older version, but I am not sure about that.

So, if anyone has any idea what I could do, feel free to drop his ideas. This is my first time dealing with Linux drivers, so I am a bit clueless.

For sure, I could just ignore the problem, since my screen seems to work fine.

Just, I can't unsterstand what is going on here... If the driver doesn't load, why is my screen working OK?

1 Answer 1


Although it's been 3 months since the question, I'll try to give a hint.

I just upgraded a box from Buster to Bullseye. Formerly I used an nvidia driver, but it was already obsolete in Buster and then removed in Bullseye, so I had to switch back to using nouveau.

After that, X either did not start or started in a low resolution (640x480 I guess).

I played a bit with xorg.conf, but it went nowhere. Then I remembered that xorg.conf is not necessary to start Xorg anymore, since it can autodetect most settings on startup.

I renamed /etc/X11/xorg.conf to /etc/X11/xorg.conf.bkp and the next startup was a flawless success. (The xorg.conf was a remainder from earlier times when I used an nvidia driver and had to customize something.)

Quote from the Debian Wiki:

If xorg.conf is missing for some reason, Xorg will probe your hardware on every startup. Though this works fine in most cases, some settings remain inaccessible.

UPDATE 2022-07-10: I guess I found an alternative solution.

Go to the nouveau/VideoAcceleration documentation page, and find the engine used by your card. In your case it probably goes as:

VP4.2: NVC0-NVCF (GeForce 400, 500 series; corresponds to VDPAU feature set C)

Scroll down for the Firmware section, read it and realize the sad fact that VP1/2/3/4/5 firmware is not packaged by Debian (probably due to licensing limitations). The second part of the documentation describes how you can download an NVIDIA driver and extract the missing stuff by hand.

Special notes for Debian (Bullseye) users:

  • One of the steps mentioned is a python2 script. Make sure you have the python2 package installed to run it.
  • The last two commands (mkdir and cp) require root privileges. You should prepend a sudo to make them work.

Credits to Ilia Mirkin.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .